Back to the main site

Need some help with writing installer - winetricks problem


#1

Trying to get a wine steam game working with lutris. Installs fine, however, it would require mscorefonts package from winetricks. No problem, right? Just write a task for that and we should be good to go. Sadly that doesn’t really work.
My installer:

name: Planetbase
game_slug: planetbase
version: Planetbase Winesteam Installer
slug: planetbase_winesteam_installer
runner: winesteam

script:
    game:
        appid: 403190
        prefix: $GAMEDIR/prefix
        arch: win64
        
    installer:
    - task:
        description: Setting up wine prefix
        name: create_prefix
        prefix: $GAMEDIR/prefix
        arch: win64
        install_mono: true
    - task:
        description: Setting windows version to windows 7
        name: winetricks
        prefix: $GAMEDIR/prefix
        app: win7
    - task:
        description: Installing mscorefonts
        name: winetricks
        prefix: $GAMEDIR/prefix
        app: corefonts
        
    winesteam:
        UseGLSL: disabled
        dxvk: true
        dxvk_version: '0.63'
        version: staging-3.12-x86_64

However, when I try to execute my installer I get this:

Executing cd /home/grizeldi/Games
Executing cabextract -q -d /home/grizeldi/.local/share/lutris/runners/winesteam/prefix64/drive_c/Program Files/Steam/steamapps/common/Planetbase/prefix/dosdevices/c:/windows/temp/_corefonts /home/grizeldi/.cache/winetricks/corefonts/arial32.exe
Executing cp -f /home/grizeldi/.local/share/lutris/runners/winesteam/prefix64/drive_c/Program /home/grizeldi/.local/share/lutris/runners/winesteam/prefix64/drive_c/Program Files/Steam/steamapps/common/Planetbase/prefix/dosdevices/c:/windows/Fonts/program
cp: cannot stat '/home/grizeldi/.local/share/lutris/runners/winesteam/prefix64/drive_c/Program': No such file or directory

Now I assume that lutris forgot to use the quotation marks and it cuts the path at the space in “Program Files”? If I install corefonts manually through winetricks GUI it works fine though. What can be done about this? Or is this a bug that should be reported to github?


#2

Yes please.


#3

Done.


#4

Is it a 64bit prefix?
Try adding arch: win64 to your tasks and some stuff doesn’t like installing within the Lutris terminal so you can do this

-execute
command: WINEPREFIX=$GAMEDIR/prefix winetricks corefonts
terminal: true

I had to do something similar to get .net4.0 and 4.7.1 to install with the installer script, but I haven’t had any issues with corefonts doing it like this

-task
arch: win64
app: corefonts
name: winetricks
prefix: $GAMEDIR/prefix


#5

I have tried with arch: win64 before, but nothing changed. Just tried it again with same result.

Trying to manually execute the command in the installer, a terminal pops up, saying “/bin/bash: Files/Steam/steamapps/common/Planetbase/prefix: No such file or directory”. Obviously, missing quotation marks, so I changed it to WINEPREFIX="$GAMEDIR/prefix". After that an empty terminal pops up, with just bash’s $ sign and does nothing.


#6

Hmm… There’s gotta be either a typo somewhere or something wrong with your Lutris. I only get that when there is a typo in the script