Need some assistance, please!


I’ve tried several times to install League of Legends via Lutris and it keeps failing about halfway through the install with this error message:

Installing League of Legends

PermissionError(1, ‘Operation not permitted’)

I’m running Debian 10 on my HP Chromebook. The install of all the prerequisites such as WIne, additional libraries, and Lutris all install without an issue. I have even blown the OS away several times and re-loaded and same error will come up. I’ve looked online for this particular error and can’t find anything definitive. I see several postings for a PermissionError(13, ‘Operation not permitted’), but nothing for what I’m seeing. I installed the apps in their default install directories. However, for the install of the games, I have it pointed to a sdcard that is formatted in exFAT and mounted as /mnt/chromeos/removeable/sdcard.

If anyone has any ideas of how to fix this I would be grateful. If there is somewhere I can maybe grab log files that can give a more detailed idea as to what this issue is would also be appreciated. Thanks!

Also, I seem to have an older interface this time around. I remember, when I had installed Lutris before, that the interface was a bit more updated than this. I remember seeing a button for Discord and others. Also, running Lutris in Lutris -d mode to capture logs. However, with this interface, I’m not seeing a Logs button for my to extract.

Hello, try with a ext4 formatted drive, do you obtain same error message?

Unfortunately, I only have 3 format options to choose from, FAT32, exFAT, NTFS. I tried with FAT32 before, same issue. I’m going to run Lutris in debug mode and post the output in a sec.

OK, I have the debug info posted below. Can someone please take a look and see if anything can be isolated as the issue? Thanks in advance!

wine does not support to install and launch game from fat32, ntfs and extfat partition.
Use Linux partition like ext4.