My games used to launch fine but dont anymore (Wine?)

I just got Lutris a couple days ago and am excited about playing games on linux. I have used linux for various server things for a while but recently installed it on an ssd. I can do pretty much anything i need so i wanted to try running some games after learning about lutris from Level 1 Linux / Linus tech tips.

I installed Overwatch and played it with no issues other than whats expected performance wise. At the same time i installed Osu! in the background while in the middle of a game in overwatch, and Osu is is a game that launches itself from the installer automatically. It came up while in overwatch and I hit Alt+F4 to close it and it closed Overwatch as well.

Afterwards both Osu and Overwatch launch in full black screen across both of my monitors with with a basic Wine interface. Osu gives the error “unable to obtain graphics context” with its respective crash dialogue and symbol in background (edit: the window is in 1 bit red color like nothing graphical is launching properly). And when overwatch was installed completely would be similar (until i decided to reinstall everything related to lutris, now its just a black screen that never ends). The problem is that Osu runs just fine when played by the same wine instance as the installer. The installer ran fine when i reinstalled overwatch. But wont run again to sign in and install the game again.

I have tried reinstalling everything including lutris after purging and autoremoving things related to lutris and wine. I have also tried several configuration changes in the lutris settings related to wine.

I feel like im just missing some graphical setting, driver, library or something im not sure. I just hate that it worked and then didnt. And now only partially works. I also tried installing a game called Steins;Gate 0 which uses winesteam but that didnt work from the begining because there is no official installer. But now it wont launch winesteam to install it either. I have not tried other things because there are only a few games i want to play that are not already on steam (or steamplay).

Thank you very much for looking and i hope someone can help me. (And i hope i can post this within an hour of signing up for the forums).

My system is:

Ubuntu 18.04
Ryzen 1600X
Nvidia GTX 970 with Nvidia drivers

I’m almost sure it sadly won’t help, but I had a bug with dota 2 and Vulkan and all my DXVK games were broke afterwards. The solution was to go to ~/.cache and delete my radv cache files. That’s AMD, but there might be the NVidia equivalent of shaders in the same folder.

If that doesn’t work, I’d still seriously consider looking for corrupt cache files (that may not be excluded on apt/synaptic/whatever operations)

What version of the nVidia drivers are you using? Also, has anything changed since you had the games working in the past? (Perhaps updated nVidia drivers?)
I am using DXVK with a GTX 1070 and have not seen any issues on my end. The nVidia 396.24 graphics driver from System76 is what’s on my machine. (It’s a System76 laptop I should note)

Also, out of curiosity are you using the default Ubuntu desktop (gnome?) For some reason Gnome seems to behave inconsistently with full screen games, and I’m not sure why. Some titles crash the display manager and send you back to the login screen, other titles launch to a black screen of death. Furthermore, gnome behaves differently with AMD and nVidia GPUs. I’m not sure why, but it’s irritating.

I recently switched to Kubuntu (ubuntu with the KDE desktop) and I haven’t had any issues with any games at all. It is going to be my desktop of choice from here on out.

As a last ditch effort, this is what I’d drive if I was you:

  • nuke+pave and install kubuntu (may need to do nomodeset because nvidia is nvidia)
  • install Wine-staging via these commands:
  • install Lutris, and try to play your games again.

That way, your setup and my setup will be nearly identical. And it works like a charm on my machine.