Back to the main site

Multiple problems in Uplay's Farcry4

Hi every1

edit: problems #1 and #3 are solved. See post bellow.

I’m trying to play Far Cry 4 through Uplay’s launcher and I’m having a few issues. First, yes, I have added the FarCry4.exe file and set it to winxp. Have also disabled in-game overlay.

Problems:

  1. No sound in game menus and in-game. Works fine in intro and cinematics intro. I have tried to switch from displayport to stereo headphones, with no luck.

  2. Game won’t display controller’s buttons properly, just a bunch of orange question marks. Controller is a Xbox 360.

  3. Strange object rendering behavior in-game. Trees and shadows will appear and disappear, apparently based on angle to view.

Some screenshots:
https://i.postimg.cc/PJWzcbzc/fc4.png

–submit-issue:

2020-02-09 14:46:42,641: Running Lutris 0.5.4
2020-02-09 14:46:42,641: Using X. Org
2020-02-09 14:46:42,641: Running Mesa driver 19.2.8 on Radeon RX 570 Series (POLARIS10, DRM 3.33.0, 5.3.0-29-generic, LLVM 9.0.0) (0x67df)
2020-02-09 14:46:42,641: GPU: 1002:67DF 1DA2:E353 using amdgpu drivers
2020-02-09 14:46:42,657: Vulkan is supported
2020-02-09 14:46:42,658: Updating DXVK versions
2020-02-09 14:46:43,160: Updating D9VK versions
2020-02-09 14:58:53,576: Shutting down Lutris

Logs:
https://paste.ubuntu.com/p/cRyxzrKP2t/
(last few errors are from when I unplugged the controller, I believe)

Thanks o/

lutris -d:
https://paste.ubuntu.com/p/vpg5QzgwRQ/

So, I have solved two of the three problems.

Audio was fixed by running winetricks and installing xact_x64.
Rendering artifacts fixed by reverting dxvk to 1.4.4.

Gamepad still not working =( Have tried all the x360ce options, setting path to executable, 32 and 64 bits, no luck.

Any ideas?

Cheers

You are running into the same problem Windows users have. Controller support in Far Cry 4 and Primal is broken for anything other than a small group of controllers. My solution was to use SC-Controller to map my controller to the keyboard inputs. I ended up with two profiles one for walking and one for driving.

There’s another bug you need to watch out for. Don’t change mouse keybinding in the game settings this will break the grapple.

There’s a sound bug in the cut scenes. The fix for this is to set wine to XP.

These fixes also work for Primal