Multiple Errors, Can't Install Games, Games Don't Start, Crashes

Hi, I’ve been trying to migrate to linux, and today I tried setting up my gaming enviroment, both with native linux games and windows games, I’ve used Lutris to facilitate the use of wine, plus all my agmes are in one place, for the most part I’ve had sucess, but I had some problems:

  1. When using Lutris, it opens up a very small steam window, but it is blanck and transparent.

  2. Sometimes when I close a game/steam, i3 stops working, can’t switch workspaces, open a terminal, maybe it’s because a game is running on the background. For example, I stopped playing tf2, closed the game and couldn’t click anything in Lutris, then it became all black.

  3. I run all games in windomed, some show the background (top/left side), like the gaps in i3, but just on top and left, I’ve had the mouse fly of screen to the side which prevented me from moving my camera in-game more than 140 degrees, I’ve had this happen in in scp secret lab.

  4. Sometimes Lutris becomes completly black.

  5. How do I install game DLC throught Lutris?

  6. Today I had 4 game syncing errors appear, even tought steam status tells that steam is operation.

  7. Path of Exile completly doesn’t work, no error even. Some native games don’t work too, like prison architect or black mesa.

Any help would be appreciated. If you need any more info just ask.

Seems that the syncing issue happens because I have both steam running on wine and native linux steam running.

My Specs:

  • Arch

  • GTX 970, Asus B350 Plus, Ryzen 1600, 2x4gb G.Skill Tatical 2666mhz Ram.

Hi, schofts

For gaming purposes I would recommend a different window manager, for example try Openbox or xfwm4. Tiling window managers don’t always play nice with wine, which I think is probably your major issue for:

Installing games is done through the website or you can do so locally/manually. If you have a certain game which has a DLC or Expansion Pack you can try to install it by right clicking on a specific game (which is already added to your library) and ‘Run EXE inside wine prefix’.

Otherwise you can try a manual installation.

You are probably missing some dependencies on your system. Check what the terminal output is for the games. In addition, you have an option to make the game launch from a terminal in Lutris if the game is already added.

Hi, I’ve heard many people that use i3 without any problems, and I really would prefer i3, I’ve made some changes to the config.

The problem is that path of exile doesn’t show a error, it just says quitting, yes, in the terminal. It displays that it is contacting a wine server for 1 minute, after that it says that it is quitting and killing the processes.

Will try posting on the i3 forum, i3 supports floating well and is very customizable, there’s probably ways to solve this issue in i3 itself.

Do you have wine natively installed? If you don’t, install it.

As for Path of Exile, which version have you installed from the website? Currently, I have the standalone version and the only thing that I have modified/removed are the arguments which has resolved some issues on my end with the game.

I gave you the suggest for the window manager because when I was trying i3 it wasn’t playing very nice with wine but that was a while back. Most probably it is fixed now I am not sure… but with a quick search I found this:

I have wine.

Poe, I tried the 2 install scripts for the steam version. Will try the standalone, but the script is so old for that one I didn’t even try because I thought that it wouldn’t work.

I don’t play fullscreen games, so no problem for me.