Back to the main site

Multi Monitor

3 monitors connected; trying to get No Mans Sky to output to my monitor of choice.
For reference connections are HDMI, DisplayPort, DVI.

No Mans Sky graphics set to fullscreen output; changing in game monitor from primary to secondary does nothing.
Changing from fullscreen to windowed is as close as I can get to be able to move the window to my main monitor.
Setting it borderless make the game window as wide as my 3 monitors but stuck on the right hand screen.

I have tried fiddling with virtual desktop under each graphics setting and it just doesn’t seem to change/do anything.
Changing the virual desktop setting with winecfg does nothing.
I have also tried changing fullscreen sdl under each setting, which again doesn’t do anything.

Does anyone have any suggestions, either how to have boderless work properly or have fullscreen output to monitor of choice.

Thanks kindly,

I had the same issue with WoW only opening on my primary monitor no matter what I set my in-game settings to. My solution was to use a program called devilspie (might have been devilspie2 as the original is unmaintained since many years - can’t really remember). You can define rules for windows, for example if the title contains “firefox”, move it to workspace A / monitor B / position X,Y / resize to W,H and so on. This worked great to force the game to open up in fullscreen on my secondary display. Plenty of guides available on how to configure it, hope it helps.

Try pressing the super key (may be windows key on your keyboard). Does it display all the windows you have open? Try dragging the full screen window to a different monitor. Then press Esc.