Mudrunner doesn't work

Hi there,

i’ve mudrunner on epic games, but it doesn’t work.
If I use DXVK it doesn’t start giving these errors:

00de:err:seh:RtlUnwindEx invalid frame 230008 (0x132000-0x230000)
00de:err:seh:call_stack_handlers invalid frame 230008 (0x132000-0x230000)
00de:err:seh:raise_exception Exception frame is not in stack limits => unable to dispatch exception.

If I uncheck DXVK, so using DX9 the game start but crash just before star tutorial.

How i can solve it?
I’ve Debian 10. My pc spec are i7 4700mq, gt 730 m, nvidia drivers 418.74 and lutris 5.7-11-x64

I am also experiencing the same problem. Epic Store just launch perfectly, and MudRunner starts, but after clicking the button to start the Tutorial the game vanishes. I also tried changing wine versions, enabling/disabling the use of system winetricks, doing the same with lutris runtime and other options, with no avail.


@flagsibh This is what i’m seeing too. I installed via Legendary, then try to run the exe via Lutris. It just exits with Return Code 1280. I’ve try a few things in winetricks (below) which hasn’t made any difference.


Hey guys, I also had the same issue with Mudrunner crashing to the desktop once I tried entering the tutorial. I also got this game from Epic, but I created a seperate WinePrefix and launcher for the game in Lutris to run it without the Epic Launcher. I was able to get the game working by simply going into Wintricks for the game, selecting Install a Windows DLL or component, and installing the d3dx9 package. I believe that is all you’ll need to get the game running, but before I got the game running, I was also getting some errors related to MSVCRT, so I also installed msvcrit in Winetricks, but that might not be needed. Other than that, my configuration is completley stock. Hope this helps you guys out!

I can confirm that all that is needed for the game to run is d3dx9, as I launched the game through legendary using my system default wineprefix, which was completley stock, and the game crashed at the tutorial again, added the d3dx9 package, and the game ran without issue.

It works good, without using DXVK.
In this week i’ll test it with a Logitech G920 and I’ll post on it my experience

Amazing. Followed your advise and created a brand new prefix, copied the game from the Epic Games’ prefix, installed d3dx9 … and I’m already running in the mud!! Thanks.

Not sure whatś going on here. Maybe the Epic Games installer script pulls off conflicting libraries.

Hi. Can you tell me exactly what to do? Can i still run the game via Lutris? I dont know much about wine so i am lost there. Thanks in advance.

Not possible to do “exact instructions”, as it depends on your current situation.

The short version to get Mudrunner to work from clean - that is having NO Epic store installed in Lutris:-

  • Install epic store using the installer
  • Finish the epic install, and install Mudrunner
  • Quit Epic store
  • In Lutris, select the game icon, then click on the up arrow next to the Wine icon
  • Run Winetricks
  • Take the option “Select the default wineprefix”, click ok
  • Click the option “Install a Windows DLL or Component”, click ok
  • Scroll down and put a check in the box that says d3dx9, click ok and wait for a minute or 2
  • Cancel to exit Winetricks
  • Run Epic again, launch Mudrunner

If you have Epic store already installed, you can clone the directory (cp -pr epic-games-store mudrunner-epic or whatever) add it to Lutris as a “new” game (click the +), copy all the game options, but change the name and all the paths over to the new directory.
Finally, run winetricks on it, select default, install DLL etc, and select install d3dx9.

Will not affect your other Epic store install, unless you mess up the paths :slight_smile: )