Mouse Acceleration Always Stuck On (Overwatch | Borderlands | Ubuntu)

Seems like no matter what I do, I can’t ever get mouse acceleration to stop when playing any games in Wine.
I’ve tried forcing xset m 0 0 and xset m 1 which fixes mouse acceleration while in the desktop, but never with games running in wine like Overwatch and Borderlands 1.

Distribution: Ubuntu Budgie 17.10

System Information

Device: MSI GS73VR-7RF (Stealth Pro - 120hz panel variant)
CPU: Intel i7 7700HQ
GPU: Nvidia GTX 1060 6G (Muxless - Nvidia PRIME Only - Also stuck at 60hz for some reason.)
GPU Driver: 384.111

In native games I don’t seem to notice much in the way of mouse acceleration (say source engine games with native linux builds, and a binary port of Unreal Tournament 2K4.) so I can’t really say why. Even tested different mouse warp settings but either didn’t change functionality or broke mouse input for the game(s).

Couple of random thoughts:

  1. Your mouse might have acceleration. I have a roccat and I had to install Roccat Tools to change stuff for the mouse itself.
  2. Check Archwiki:
  3. For Overwatch, you should use Staging 2.21 with Nvidia. And then you have to “killall Agent.exe” after starting Overwatch or your mouse might spazz.
  4. For Overwatch, you should use Nvidia 390.XX for more fps (not mouse related, but still important to note)
  1. Already used multiple mice, and none of then naturally have acceleration in a native windows environment. (some bargain bucket Gamdias mouse, a Logitech G603, and a Razer Deathadder 2013) They don’t have acceleration when xset m 1 1 or xset m 0 0 are set in linux.
  2. doesn’t help. libinput Accel Profile Enabled (290): 1, 0 regardless of is set in 50-mouse-acceleration.conf | almost as if this build of ubuntu doesn’t even load anything from xorg.conf.d
  3. I left that shit at default.
  4. 390 fucks my display output for that laptop (gotta love muxless.)

And did you try “killall Agent.exe”?

That only resolves mouse jerking, not acceleration.

Hey, try this guide. Its an old one but works fine on ubuntu 16.04. :slight_smile:

Again, Same result as what you have on the archlinux wiki.

It does disable mouse acceleration but it seems that WINE says “fuck that shit” so it might be an issue with WINE emulation in general and how it handles trapping the mouse within the window?

Edit: Will be uploading a couple videos in a bit, one in a game running natively (Unreal Tournament 2K4) and with Overwatch, which i did manage to find a ‘new to me’ bug involving window resizing. Which is interesting because it’s starting to make me believe it’s an issue specifically with how WINE handles mouse capture even more.

edit 2: As for the method im using to disable mouse acceleration in X11, I’m using the libinput method outlined on the arch wiki.

Section "InputClass"
Identifier "My Mouse"
Driver "libinput"
MatchIsPointer "yes"
Option "AccelProfile" "flat"

I started using “xset m 0 0” on startup myself, since setting it in X11 didn’t seem to stick. Now I have absolutely no acceleration in Overwatch. Wine doesn’t do anything with the mouse. Mouse warp override is the only thing I think, and I don’t need to set it for anything.

Anyways, I’m interested to find out if/how you can fix this.

Did you try a different DE / WM yet?

1 Like

Budgie/Gnome3, XFCE4 so far. as for WMs, only what those two use.

Update: Tried IceWM, seems to not have any Mouse Acceleration now. still need to do more testing but i think it’s something to do with how Gnome and XFCE handle mouse input or maybe they do something that overrides xorg.conf.d

Yeah, I had the issue with Gnome3 that it wouldn’t respect what I set in Xorg. Which is why I was setting “xset m 0 0” in Startup applications. That would work.

Gnome has a mouse settings dialogs that has mouse acceleration. I never have tried Budgie, but if it gnome3 based, you might have to find something similar.

XFCE I only use on laptops where I don’t game, but I’m sure it has settings somewhere.

Myself I use AwesomeWM for minimalist pleasure, I still set “xset m 0 0” on startup because I’m paranoid.

That’s the weird thing. While gnome3 amd xfce would technically honor xset m 0 0 or 1 1, they wouldnt honor it in WINE applications. Definately going to need to look into it more, but in the meantime Ill stick to ICEWM for the moment when i want to game with WINE in general. Probably faster anyway since ICEWM doesnt really do much compositing as far as i see.

Are you playing Fullscreen? Or windowed (fullscreen)?

Only thing that jumped into my mind is that with Fullscreen you bypass Gnome3/XFCE altogether. While with Windowed (Fullscreen) you actually let the Window manager handle it.

Tried both fullscreen and windowed

Aight. Think I’m out of ideas you can try.

Let us know how you end up fixing it.

Just gonna slip on over to Openbox and MATE and call it a day.