Most of my GoG Game send me a "Exit with returncode"

Okay for exemple i tried to install Outlaw, this happened while Lutris is on installing game data phase

00b:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
000b:fixme:winediag:start_process Wine Staging 4.9 is a testing version containing experimental patches.
000b:fixme:winediag:start_process Please mention your exact version when filing bug reports on
000f:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
0012:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
0019:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
001f:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
0025:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
0009:fixme:process:SetProcessDEPPolicy (1): stub
002a:fixme:process:SetProcessDEPPolicy (1): stub
002a:fixme:win:DisableProcessWindowsGhosting : stub
002a:fixme:graphics:ShutdownBlockReasonDestroy (0x1008c): stub
002a:fixme:graphics:ShutdownBlockReasonCreate (0x1008c, L"Installation en cours"): stub
002a:fixme:rstrtmgr:RmStartSession 0x50c010, 0, 0x50c014 stub!
002a:fixme:graphics:ShutdownBlockReasonDestroy (0x1008c): stub
002a:fixme:graphics:ShutdownBlockReasonCreate (0x1008c, L"Installation - Outlaws"): stub
002a:fixme:msg:ChangeWindowMessageFilterEx 0x1009a c05d 1 (nil)
002a:fixme:msg:ChangeWindowMessageFilterEx 0x2009a c05d 1 (nil)
002a:fixme:msg:ChangeWindowMessageFilterEx 0x100a4 c05d 1 (nil)
002a:fixme:msg:ChangeWindowMessageFilterEx 0x200a4 c05d 1 (nil)
002a:fixme:shell:SHAutoComplete stub
002a:fixme:msg:ChangeWindowMessageFilterEx 0x100c4 c05d 1 (nil)
002a:fixme:wincodecs:JpegDecoder_Frame_CopyPalette (0xbd95a4,0xbd9120): stub
002a:fixme:gdiplus:resample_bitmap_pixel_premult Unimplemented interpolation 6
002a:fixme:wincodecs:JpegDecoder_Frame_CopyPalette (0x20491c,0xc295d0): stub
002a:fixme:wincodecs:JpegDecoder_Frame_CopyPalette (0xc28344,0x204390): stub
002a:fixme:wincodecs:JpegDecoder_Frame_CopyPalette (0xc288a4,0x204390): stub
002a:fixme:graphics:ShutdownBlockReasonDestroy (0x1008c): stub
Waiting on children
All children gone
Exit with returncode 1`

And same thing for The Witcher 3, but the returncode is 0.

I have the exact same problem since version 5.2.2
Whatever the game is, Alpha Centauri, Amerzone, doesn’t matter: The prefix is created, the game installs but at the end always the same message:

Waiting on children
All children gone
Exit with returncode 0 ***(sometimes 1 instead of 0)***

So I always have to cancel installation at the end. I completely removed and re-installed both wine and lutris but still the problem is the same.


Same here, Lutris on Arch Linux.
Only happens with GoG-Games for windows.

Hi there! I was having this error myself. I installed Wine staging and set the [Wine Runner] configuration to use my system version of Wine settings. It works just fine, now.

Hey all.

I run Vampire the Masquerade: Bloodlines in GOG galaxy with Lutris. I don’t think it’s supposed to be done like this, but I choose “GOG” from the games search as pictured here:

After I install GOG Galaxy, I simply install the game I wanted and run it. This has worked for Vampire the Masquerader: Bloodlines, but it hasn’t worked this same way for Metro:2033 which I also have through GOG. The reason I’d say it doesn’t work is because Metro lost some sound quality and the graphics suffered. Perhaps tweaking wine could fix this.

I follow the recommended settings for playing Vampire, and there isn’t a single hitch, but it’s fairly non-demanding as games go.

Same here

I recommend installing GOG games separate from GOG Galaxy and then scan/import lutris games folder with GOG Galaxy.

That we each games has it’s own prefix

My example /home/dp27thelight/Games

Have GOG Galaxy Scan/Import then if game doesn’t launch in GOG Galaxy try through Lutris.

Another issue with GOG on Lutris is that many people made bad install scripts on lutris that aren’t configured to work.

Unfortunately Steam and Steam Proton seems to be getting more attention despite being nothing special, it’s still just wine running a windows game.

I much prefer DRM-Free.

Now you can always install GOG games manually and I’ve found about 50% of game tend to work with this method, and as your stating the installers always fail that’s a no issue, but you need to relocate the executable after the installer is run and select the game executable.

The other sweet aspect to a GOG installed games is that you can now copy the prefix folder to any usb/hard drive/ computer. Then install Lutris in easily configure the game through Lutris. Don’t have to zip or reinstall the game on future computers ever again! it’s amazing and why I love GOG and DRM-Free.
I just wish GOG was getting more support for games that need special configuring. Sadly this is only partially happening typically with major popular titles.

The good news it new games always tend to work out of the box.

Nobody is really talking about it, but Cyberpunk 2077 doesn’t need a linux port because I guarantee that the game will run out of the box using DXVK.

On that note I always suggest you try running a game using DVXK first as it’s vastly superior performance and likely hood of the game working.

1 Like