Back to the main site

Most of my GoG Game send me a "Exit with returncode"

Okay for exemple i tried to install Outlaw, this happened while Lutris is on installing game data phase

00b:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
000b:fixme:winediag:start_process Wine Staging 4.9 is a testing version containing experimental patches.
000b:fixme:winediag:start_process Please mention your exact version when filing bug reports on winehq.org.
000f:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
0012:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
0019:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
001f:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
0025:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
0009:fixme:process:SetProcessDEPPolicy (1): stub
002a:fixme:process:SetProcessDEPPolicy (1): stub
002a:fixme:win:DisableProcessWindowsGhosting : stub
002a:fixme:graphics:ShutdownBlockReasonDestroy (0x1008c): stub
002a:fixme:graphics:ShutdownBlockReasonCreate (0x1008c, L"Installation en cours"): stub
002a:fixme:rstrtmgr:RmStartSession 0x50c010, 0, 0x50c014 stub!
002a:fixme:graphics:ShutdownBlockReasonDestroy (0x1008c): stub
002a:fixme:graphics:ShutdownBlockReasonCreate (0x1008c, L"Installation - Outlaws"): stub
002a:fixme:msg:ChangeWindowMessageFilterEx 0x1009a c05d 1 (nil)
002a:fixme:msg:ChangeWindowMessageFilterEx 0x2009a c05d 1 (nil)
002a:fixme:msg:ChangeWindowMessageFilterEx 0x100a4 c05d 1 (nil)
002a:fixme:msg:ChangeWindowMessageFilterEx 0x200a4 c05d 1 (nil)
002a:fixme:shell:SHAutoComplete stub
002a:fixme:msg:ChangeWindowMessageFilterEx 0x100c4 c05d 1 (nil)
002a:fixme:wincodecs:JpegDecoder_Frame_CopyPalette (0xbd95a4,0xbd9120): stub
002a:fixme:gdiplus:resample_bitmap_pixel_premult Unimplemented interpolation 6
002a:fixme:wincodecs:JpegDecoder_Frame_CopyPalette (0x20491c,0xc295d0): stub
002a:fixme:wincodecs:JpegDecoder_Frame_CopyPalette (0xc28344,0x204390): stub
002a:fixme:wincodecs:JpegDecoder_Frame_CopyPalette (0xc288a4,0x204390): stub
002a:fixme:graphics:ShutdownBlockReasonDestroy (0x1008c): stub
Waiting on children
All children gone
Exit with returncode 1`

And same thing for The Witcher 3, but the returncode is 0.

I have the exact same problem since version 5.2.2
Whatever the game is, Alpha Centauri, Amerzone, doesn’t matter: The prefix is created, the game installs but at the end always the same message:

Waiting on children
All children gone
Exit with returncode 0 ***(sometimes 1 instead of 0)***

So I always have to cancel installation at the end. I completely removed and re-installed both wine and lutris but still the problem is the same.

1 Like