Back to the main site

Mod Organizer 2 fails to install. Sha256sum vcruntime error

While trying to install Mod Organizer 2, I received this error:

sha256sum mismatch! Rename /home/amps/.cache/winetricks/vcrun2019/vc_redist.x86.exe and try again.
------------------------------------------------------
Gtk-Message: 15:10:59.692: GtkDialog mapped without a transient parent. This is discouraged.

I have tried backing up and renaming vc_redist.x86.exe but to no avail. Also I’m using the latest wine-staging to install.

Did you install vcrun2019 from winetricks?

Mod Organizer 2 is broken in Wine due to lack of support USVFS as described here:
https://appdb.winehq.org/objectManager.php?sClass=version&iId=36189&iTestingId=104086

It will start however if you install the latest VC Runtime from Microsoft here:
https://support.microsoft.com/en-gb/help/2977003/the-latest-supported-visual-c-downloads
I’m not sure why the install through winetricks for this didin’t work. Nonetheless fixing this will still not launch the games with mods due to the before mentioned lack of USVFS support.

By coincidence I was fiddeling around with “Gamebryo Engine Era” games over the last week and got Mod Organizer 1.3.11 running perfectly fine in a 64Bit Win10 Prefix with only quartz added through winetricks, running the prefix with the lutris-5.6-6 version of wine.

Mod Organizer 1.3.11 is still available here:

Latest FOSE (http://www.fose.silverlock.org/) also works fine with MO1.3.11. MO will however “take a moment” when adding or removing mods on occasion, so a little patience is needed sometimes. :smile:

Steps for Fallout 3 (adjust for the other titles, but use the same prefix):

  1. Get Mod Organizer v1_3_11 (Not the installer version)
  2. Get FOSE
  3. Extract MO and FOSE to something nice like ~/Games/Windows/tools/*
  4. is the fun part :smile:
    (Paths are only suggestion, but will be used in the following setup. Also remember that you’ll find your root directory as drive Z: in any later dialogs in MO!)
  • Create a new entry through the + icon in Lutris
  • Name it Mod Organizer
  • Select Wine as the Runner
  • In the “Game Options” tab select “/home/USER/Games/Windows/tools/Mod Organizer 1.3.11/ModOrganizer.exe” for the Executable
  • Select “~/Games/Windows/prefixes/Gamebryo” as the prefix
  • Leave “Prefix architecture” on “Auto”
  • In the “Runner options” tab activate “Enable DXVK” and “Enable Esync”, even though it is not directly needed by MO itself. Click Save to obviously safe the launcher.
  • Before running MO, preferably click on “Wine configuration” on the right pane. The prefix will now be created and the wine config window will appear. Nothing to do here, simply click OK.
  • Run “Winetricks” from the right pane. Click “Select the default wineprefix”, click OK.
  • Select “Install a Windows DLL or component”, click OK.
  • Scroll down the list and select “quartz”, click OK. This will install quartz and eliminate some problems regarding sound in FO3/FNV.
  • When the winetricks window reappears click Cancel until it’s gone for good. :smile:
  1. Install the games using the same prefix to something nice like ~/Games/Windows/installs/[AnyGame]
  2. In the case of Fallout 3, copy the fose.exe and all dll files into the game directory where Fallout3.exe is located. Adjust accordingly for other games.
  3. Launch your previously installed Mod Organizer and follow the steps to set it up as described in this GamerPoets miniseries here (It’s 4 videos as a step by step guide :wink:):
    https://www.youtube.com/watch?v=OHgULB431Os
    You can skip the steps for linking with nexusmods, as it seems like it’s not working. So for now it’s manual downloads all the way to be placed in the */Mod Organizer/downloads folder. Also note, that the videos use the installer and not the zipped version, but it works.

Quite some work, but it’s possible. Just as a reminder: Some actions in MO might return an error for a missing *.esp on occasion, if you activate an installed mod on the left pane of MO. Just wait a couple of seconds, deactivate and reactivate the mod. The error message shouldn’t show up again and it should be fine.

As all games and MO are in the same prefix, you can create the desktop links and use those instead of the games executables in the individual Lutris launchers for the games themselves. Just remember to install them all in the same prefix. This is crucial for the setup to work correctly. :wink: