Back to the main site

Minecraft Dungeons - Wine/DirectX issue

After installing Minecraft Dungeons using Lutris, i try running the game and get a rather painful error, which I’m not at all surprised about. The installation process worked just fine, i can open the launcher and download the game. However when i actually try to run the game, the error as shown in the image comes up.
unknown

I tried to solve this by installing directx packages into wine, but this seemingly had no effect at all. Another thing is that most of the errors that appear in the logs, all happen when launching the MC Launcher. (Which works fine it just takes a while) Nothing new appears in the logs when starting the game.

Logs:
Minecraft dungeons output - mcd_output - Pastebin.com
Lutris Debug output - lutris_debug_console - Pastebin.com
System info:
OS - Manjaro Linux x84_64
Kernel - 5.15.55-1-MANJARO
Desktop Environment - Plasma 5.24.6
CPU - AMD Ryzen 5 1600
GPU - AMD Radeon R7 240
More details here - https:// pastebin. com/3FEiAKMv

Any help in solving this issue would be much appreciated!

Update:
This issue has now been solved, thanks to the kind support from the Discord server.

Basically, the problem was that my GPU didn’t support vulkan, so i had to disable DXVK and VKd3d. I hope this can help somebody in the future!