Metroid AM2R Version

Hello, I’m brand new here so I don’t know where I should put this. Basically, there are two versions of Metroid AM2R available on Lutris (v1 and v1.1), neither of which are recent versions. I guess those were the last two versions to have (unofficial?) linux builds released. Version 1.5 adds ‘official’ linux support, so we can find the new version here:

Hi, @geiluigi. I’m new here as well, but AM2R 1.5 was something I recently noticed as well.

Are you sure that the 1.5 is in any way official? From what I understand, anything past 1.0 (or 1.1.) was not official. Which is also why 1.5 comes as a (binary) patch over 1.1.

I think we could just modify the 1.1 install script to use the 1.5 installer, but for that we would need to have a stable download link for it. The one on Reddit is on a click-through file locker, which is hard to automate. If one were to upload the 1.5 patch to, that might make it pretty easy to create a new 1.5 installer.

I managed to get it running (on Manjaro), but it’s a bit messy.

What I did was:

  1. get original (not the Linux version on Lutris, mind!)
  2. get the 1.5 patch
  3. unpack the 1.5 patch and put the into its folder
  4. run the as instructed
  5. install steamrun (on Arch/Manjaro it’s in AUR)
  6. create a new game entry in Lutris and:
    • select the Linux runner
    • put steamrun in the Command Prefix under the (advanced) System Options

This worked for me. But no idea how to get package this on Also, I would much prefer a cleaner version than using Steam’s runtime as the workaround, if anyone has a good suggestino

My gamepad/controller still does not get recognised by AM2R, but I can managed to use it by mapping the button presses with keybindings using antimicroX (QJoyPad also works).

With regard to the “unofficial” status of the latest version, it’s worth mentioning that the original linux builds were also unofficial, in that they were essentially old development linux binaries shoved together with current (at the time) assets. There was never an official linux build of the game. However, there are people continuing to work on the game. They have a discord group, you can talk to them. Those people have now released ‘official’ linux builds of the game, to whatever extent any new version can be. What could qualify as official, now that the original creator of the game was DMCA’d twice and can’t legally keep working on it? I don’t feel like there’s anything less official about v1.5 than v1 or v1.1.

1 Like

About getting the patcher to work…

I’m on gentoo, and there was very little difficulty getting it to work. I did use the ZIP provided by lutris as the base. The only complication for me was that the lutris ZIP has the am2r binary named in all caps, whereas the patcher expects it in all lowercase. Easy fix, and then it worked.

About joystick support, I talked with one of the devs, and he said am2r has a strange way of detecting joysticks, and that it would be fixed in v1.5.1 (or I guess v1.6­­ ­- people are talking about 1.6 now, even though there hasn’t been a 1.5.1 release)

That’s great to hear. So, the only hurdle right now is that the 1.5 patch is not on a permalink, but in a file locker.