Menu buttons / UI misplaced

Hello, I have a weird issue with some games where, if I change the resolution (lower it so I can get more performance at the cost of some visuals), all the buttons move out of place in the game.

For example, in Overwatch 2: my laptop’s original screen size is 1920x1080, but in the game, I have 1280x720 selected, however, all the menu buttons get out of place as shown in the pictures (sorry for using a cellphone, I couldn’t use print-screen):

= The mouse above “Play”, while selecting the “Heroes” tab. The “Options” button being selected with the mouse far away. The “Yes” button being above, it gets tedious with small ones like those. =

Anyone knows a solution? I tried a few: Windowed (Virtual Desktop) on Lutris won’t work, it only launches a weird empty screen with a piece of my current desktop background and an icon of the game’s launcher that doesn’t works at all; tried the Virtual Desktop in Wine Configuration too, but I think it only applied to the launcher or toggled itself off randomly after; in the game I tried Borderless Fullscreen, changed the Aspect Ratio, among other small things, but none worked.

So far, the best and temporary fix is changing my laptop’s resolution to the desired one before launching the game and then revert it back after being done. It’s not bad, takes like 10 seconds to do, but I was wondering if there is a better fix I could be missing.

1 Like