Back to the main site

Mass Effect Andromeda won't start

RESOLVED
Had to change the Vulkan ICD Loader from Auto to “AMDVLK/AMDGPU-PRO”


EDIT: I got Origin to launch by “installing” Origin, and point it to the Andromeda prefix. I’ll try and see if I can launch the game after the game finishes installing.


Here’s the log:

Started initial process 44416 from /home/yamiyuki/.local/share/lutris/runners/wine/lutris-ge-6.16-1-x86_64/bin/wine /home/yamiyuki/Games/Lutris/Windows Games/mass-effect-andromeda/drive_c/Program Files (x86)/Origin/Origin.exe
Start monitoring process.
esync: up and running.
Initial process has exited (return code: 0)
info:  Game: OriginThinSetupInternal.exe
info:  DXVK: v1.9.2-21-g2e66f45a
info:  Found config file: /home/yamiyuki/Games/Lutris/Windows Games/mass-effect-andromeda/dxvk.conf
info:  Effective configuration:
info:    dxgi.nvapiHack = False
info:  Built-in extension providers:
info:    Win32 WSI
info:    OpenVR
info:    OpenXR
info:  OpenVR: could not open registry key, status 2
info:  OpenVR: Failed to locate module
info:  Required Vulkan extension VK_KHR_surface not supported
terminate called after throwing an instance of 'dxvk::DxvkError'
Monitored process exited.
Exit with return code 0

Why is it looking for VR components?

System info:
Operating System: Kubuntu 21.10
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.13.0-25-generic (64-bit)
Graphics Platform: X11
Processors: 24 × AMD Ryzen 9 5900X 12-Core Processor
Memory: 62.7 GiB of RAM
Graphics Processor: AMD Radeon RX 6900 XT

Prior to upgrading my system, I was able to launch Andromeda on my system with i5-6500 + GTX 1060.

No issues here, make sure you use the origin client only to install and launch the game.

Odd. Origin won’t launch for me.

I’ve tried to point it to ME:A itself (which I copied from my old PC), but it still won’t launch.