Back to the main site

Maintainer of https://lutris.net/games/battlenet/


#1

Maintainer of https://lutris.net/games/battlenet/ pls update DXVK


#2

You can right click your application in Lutris and go to Configure->Runner options and choose the DXVK version you need there.


#3

Hm okey but 7.1 is not in the dropdown


#4

The newest version of Lutris should show you all available DXVK versions. What distribution are you on?
If Lutris doesn’t show you the DXVK version you need, you should be able to enter it manually in the version box (In your case you probably have to enter 0.71) and it will automatically download it for you.


#5

Oh ok, lutris 4.19 dxvk max is 0.65
Distribution is Manjaro with Plasma DE and kernel 4.18


#6

It’s not…


#7


#8

I wouldn’t say that yet. I encountered this in some random virtual machine before. It seems to happen when the dxvk directory does not exist for some reason.


These versions are only shown as fallback when lutris fails to get the currently available dxvk versions.

@LucyDemoon does running mkdir ~/.local/share/lutris/runtime/dxvk in a terminal fix the issue with Lutris? Also, have you successfully used dxvk before with Lutris?


#9

nice thx, added the folder and now it works


#10

please fix
can’t start battlenet with any recent runner >3.10 esync or pba-firerat that worked earlier, DXVK on or off
always get this generic error with no other errors in console

i use arch with latest version and all dependencies etc.


#11

Same problem here… ;’(


#12

Debugging a game installation: To get output of an installation, start lutris in terminal with lutris -d . Try to install a game, then the terminal will contain information about the installation. Copy the logs to your favorite paste site, and put the link here. And well, you could try to look at the log for err: (but ignore the winebuilder.exe error.)

1