Magic: The Gathering Arena script fails

Hey community,

I installed Magic: The Gathering Arena before, and it worked. After the open beta started September 27th, I reinstalled the game. And after days of testing the installation always fails. It just stops with the following text.

I even removed every file from the installation path and tried it many times. How could I try to solve this?

Edit: I am running Ubuntu Mate 17.04.

Using winetricks 20180815-next - sha256sum: 99e9d80556dc1c3e3fe499059a8b7e44f6780a1aeb7cdf0bc832f99fa5bc64c8 with wine-3.10 (Staging) and WINEARCH=win32
Executing w_do_call win10
Executing load_win10
Der Vorgang wurde erfolgreich abgeschlossen
Setting Windows version to win10
Executing /home/[myname]/.local/share/lutris/runners/wine/staging-3.10-i386/bin/wine regedit /S C:\windows\Temp_win10\set-winver.reg

Do you have Wine installed in your system?
It may sound silly, but I think you have followed the instructions on the Wine page already.

The current script has a lot of patching issues, because playing MTGA requires you to reinstall the game completely, meaning patching everything again (about 50 packages). The problem is that the patching process breaks due to multithreading (suspected) in some machines, so you may incur in repeated errors. Using the current script, if you incur in one of these errors, you have to start over (which makes installing the game impossible).

I discuss an alternate method of installing MTGA in this thread. Gladly, MTGA doesn’t require complex tricks to work.

Thanks for the response.

I already got it running by adding by following this reddit idea here several months ago. So I did install MTGA on Windows and took the installation files from the Windows VM to my Ubuntu.

I’ll have a look into the alternate methods.

Edit: I can run MTGA.exe with Wine, but the update process just freezes…

But my guess is, that with the Open Beta the installation process really changed, so the script doesn’t work anymore. Maybe someone can try to fix the script?