Back to the main site

Magic: The Gathering Arena graphics not initializing


#1

Hi,

I recently installed Lutris on my Debian 9.5 machine in order to run Magic: The Gathering Arena. It appeared to install successfully, but when I try to run the program it just goes to a blue screen with the error message as follows (with the title ‘failed to initialize player’):

Failed to initialize graphics.
Make sure you have DirectX 11 installed, have up to date
drivers for your graphics card and have not disabled
3D acceleration in display settings.
InitializeEngineGraphics failed

I checked the other threads with this issue, but they didn’t seem to be applicable to my issue since by default Lutris isn’t running DXVC on my machine.

I would really appreciate any pointers anyone is able to give.


#2

The game doesn’t need DXVK to run, so either you probably have the option currently toggled ON or you don’t. First I’d try toggling it on and off. Second, make sure you have the latest wine-development or wine-staging installed in your system for generic compatibility.

You’ll also need Mesa drivers. I’m not sure mesa-vulkan-drivers are necessary, but having the full graphics stack would be ideal.

I think I got similar errors because I tried running the game with DXVK (which changes Wine DLLs), but I shouldn’t have.


#3

I had this for MTGA and another game, too.

MTGA has DXVK disabled, the other game enabled. I switched my DXVK version to 1.0, even when I don’t use it with MTGA. Now it works.

I don’t know if anything behind the curtain happened that solved it or if this is just a coincidence, but you may try that.