Back to the main site

Lutris won't start on Solus Project


#1

I just slapped a fresh install of Solus Project on a 1TB HDD by itself, and install Lutris (and what it said it needed for dependencies) along with Wine, Winetricks (installed all of the things it brings up at first launch of Winetricks), and installed Steam. When I tried to launch Lutris, nothing happened. Nothing is in the background on the System Monitor. Nothing. Please help! I wanna be done with Windows.


#2

Bump! Still having this problem!


#3

Hello BforBrian,
can you open a terminal and enter lutris -d and copy the output here?


#4


#5

I also tried install python -gobject and got an error that it’s already installed.


#6

Weird, that shouldn’t happen.
Can you also check if you have python3-gobject installed?
Since it’s a fresh install of Solus, did you install all updates before installing Lutris or did you install Lutris before updating? Have you tried uninstalling Lutris and then installing it again?
Did you reboot after updating (Just to be safe)?


#7

I may have actually installed Lutris before I finished updating, but I tried uninstalling it and reinstalling after all of the updates, and restarted my PC and nothing changed.

Also python3-gobject is installed as well.


#8

Welp, I ran some optional software updates and it completely broke Solus. So I guess I’ll try a different distro. Any recommendations?


#9

Uh, sad to hear that. Most people recommend Ubuntu for beginners. If you liked the look of Solus, you can try Ubuntu Budgie. Solus is still a fairly young project so there can be a few issues.