Back to the main site

Lutris wants to delete all data on 2nd HDD?

When I select remove on Epic Games Store inside Lutris, it is responding with ‘calculatiing…’ and then offers to “uninstall” 173GB of data from my second HDD in laptop. This can’t be right, right?

Hi,
can you tell us how you installed the Epic Games Store? Did you use a Lutris installer for that or did you do it manually? Did you change the install path during installation? If you right click the Epic Games Store in Lutris and click on Configure and then go to Game options, what is the text in the Wine prefix and the Executable options?

Obviously you should not click on uninstall in this situation, horrible things will probably happen. Also a good reminder to do some backups every now and then before it is too late.

Installed it through latest Lutris: Sources -> Lutris -> Community Installers

I changed the path to my 2nd drive and directory ‘Lutris’

Wine prefix: /mnt/CE8886B38886999B/Lutris
Executable: /mnt/CE8886B38886999B/drive_c/Program Files (x86)/Epic Games/Launcher/Portal/Binaries/Win32/EpicGamesLauncher.exe

Obviously i can’t run EGS since installer has created an exec. path pointing to non existing directory (drive_c). Something I noticed now.

Also noticed there is no folder named Lutris like wine prefix says.

Executable: /mnt/CE8886B38886999B/drive_c/Program Files (x86)/Epic Games/Launcher/Portal/Binaries/Win32/EpicGamesLauncher.exe

Lutris doesn’t install games like that.

I don’t install games like that either. And there’s only me and Lutris in here…

So could you tell us why the game installed on /mnt/CE8886B38886999B/drive_c instead of:
/home/your_profile/Games/your-game/drive_c/… ??
Your drive `/mnt/CE8886B38886999B/’ formated in fat32? NTFS? other?

They said they changed the install path to what should have been /mnt/CE8886B38886999B/Lutris. That’s also what the Wine prefix option says. But apparently that folder doesn’t actually exist. And if I understood correctly the drive_c folder on the root of the drive doesn’t exist either? Do other things like dosdevices or system.reg exist on the drive root? I can’t reproduce this situation on an Ubuntu VM and a second ext4 drive, even with messing up permissions and file ownerships. When I deliberately install something to the root of the drive lutris tells me The folder is used by other games and will be kept.

@pigwink
What distro and what version of Lutris are you using?

This is a Lenovo Legion Windows laptop with an SSD for the OS’s Win10 and Ubuntu Studio. The second HDD is internal and has a 1TB NTFS partition, which I am trying to share between Win10 and Ubuntu Studio. It is auto mounted on boot as /mnt/CE8886B38886999B/

I wanted to install Epic in Lutris on the 1TB drive, and it seems it tried to create the “drive_c” folder on the NTFS drive while installing, but failing to do so. I did not specify the drive_c folder. I also tried creating the Lutris folder. It seems this didn’t work either, still Lutris kept this info for installing and completed the task. It now looks like I have Epic installed in Lutris.

Win10 might have been putting the 2nd HDD in read only mode during this. I’m aware of the “disable fast boot” function in Win10 but if I forget to shut down windows completely it will still “grab” the drive. This might have happened during the process? Messy stuff.

So,
Ubuntu Studio 20.04.2 LTS
Lutris 0.5.8.3

Lutris and Wine are not (yet) fully compatible with NTFS drive, use a Linux partition instead (ext4).

I haven’t found any info that told me of this compatibility issue in advance. Lutris doesn’t try to prevent me from using an NTFS-partition which could lead to loss of data. I really hope a solution to this is highest on dev’s priority list.

Its typical of Wine. Wine has a steep learning curve and to use it well means learning it all. I think there were two warnings about NTFS in Wine docs but one is added below.

But, this might be a Lutris problem. It has known deletion issues. Install an item a certain way and it will delete more than it should when you delete said item. They should be working on that but it takes time.

Supported file systems:
Wine should run on most file systems. A few compatibility problems
have also been reported using files accessed through Samba. Also,
NTFS does not provide all the file system features needed by some applications. Using a native Unix file system is recommended.