Lutris trying to load bash source for Rpcs3 Instead of game file

Maybe its just not finished yet since it just got put in but i noticed when rpcs3 is run it loads the appimage with space then $0 which seems to point to the folder & file it is. I was wondering if there was a way for it to grab the folder entered in “Game folder” in the game configuration for now so it could be told to automatically run that EBOOT.BIN.
currently it loads (from rpcs3 script)-


root_dir="$(cd “$(dirname “${BASH_SOURCE[0]}”)” && pwd)"
cd ${root_dir}

./rpcs3-v0.5-6694.somethin.AppImage $0

The AppImage comes from the RPCS3 itself and I haven’t managed to get any command line argument to do anything.

I’ve also compiled the emulator from source and experienced the same issue when directly running the executable.

For now, the RPCS3 runner in Lutris will only open the main UI because it’s all it can do without proper command line options. I’ll likely post an issue on their github to ask about this.
According to this issue:, it was supposed to be fixed but it’s clearly not working.

If I run directly from appimage “./rpcs3.v0.0.5-blah.appimage /path/to/EBOOT.BIN” rpcs3 opens up & runs the game automatically, (as long as its in the rpcs3 options to start auto). does lutris have any variable from the “game directory” field to pass to a script? If there was a way for lutris to just send that pathfield as an argument after command would be way cool. Rpcs3 also has the feature to close when game closes so it would be like the rpcs3 menu isn’t there, just in the background.

Yeah, it’s in the game options, I just haven’t managed to get it working, but I haven’t tried pointing at a EBOOT.BIN file.

I’ve forgotten most of the little I knew about scripting heh, but the ps3 EBOOT.BIN stucture is always the same after the main game dir so as long as the script could call the gamepath field & did “./rpcs3.v0.0.5-blah.AppImage {gamepathfield}/USRDIR/EBOOT.BIN” it should run every game fine & close itself on exit if they check the option in rpcs3 that would be awesome, rpcs3 is on a roll lately with tons of playable status games, & alot of the ingame status seem to run ok with a little tweaking & occasional sledge hammer to a monitor :slight_smile:

I’ve updated the runner, there was a bug in how the arguments were passed. Also changed RPCS3’s main argument from a directory to a file in Lutris’ UI so it will be possible to pick EBOOT.BIN.