Lutris suddenly doesn't start anymore

I use the latest arch linux lts version.
I received this popup before lutris ran for the last time:

JSON response from could not be decoded: '{‘client_version":“0.5.14”, “gpus”:{“8086:46a8 17aa:3802”:{“vendor”:"Intel Corpor’

Now when I run lutris on command line, I get the following:

2024-01-09 15:35:15,073: Starting Lutris 0.5.14
2024-01-09 15:35:15,077: Running Intel Mesa driver 23.3.2 on Mesa Intel(R) Graphics (ADL GT2) (0x46a8)
2024-01-09 15:35:15,077: GPU: 8086:46A8 17AA:3802 (i915 drivers)
Traceback (most recent call last):
File “/usr/lib/python3.11/site-packages/lutris/gui/”, line 310, in do_activate
self.window = LutrisWindow(application=self)
File “/usr/lib/python3.11/site-packages/lutris/gui/”, line 126, in init
File “/usr/lib/python3.11/site-packages/lutris/gui/widgets/”, line 440, in initialize_rows
File “/usr/lib/python3.11/site-packages/lutris/gui/widgets/”, line 527, in update_rows
self.installed_runners = [ for runner in runners.get_installed()]
File “/usr/lib/python3.11/site-packages/lutris/runners/”, line 101, in get_installed
runner = import_runner(runner_name)()
File “/usr/lib/python3.11/site-packages/lutris/runners/”, line 261, in init
“default”: get_default_version(),
File “/usr/lib/python3.11/site-packages/lutris/util/wine/”, line 217, in get_default_version
default_version = get_default_runner_version(“wine”)
File “/usr/lib/python3.11/site-packages/lutris/”, line 140, in get_default_runner_version
runtime_versions = load_runtime_versions()
File “/usr/lib/python3.11/site-packages/lutris/”, line 35, in load_runtime_versions
return json.load(runtime_file)
File “/usr/lib/python3.11/json/”, line 293, in load
return loads(,
File “/usr/lib/python3.11/json/”, line 346, in loads
return _default_decoder.decode(s)
File “/usr/lib/python3.11/json/”, line 337, in decode
obj, end = self.raw_decode(s, idx=_w(s, 0).end())
File “/usr/lib/python3.11/json/”, line 355, in raw_decode
raise JSONDecodeError(“Expecting value”, s, err.value) from None
json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)
Traceback (most recent call last):
File “/usr/lib/python3.11/site-packages/lutris/gui/”, line 699, in do_command_line
AttributeError: ‘NoneType’ object has no attribute ‘present’
(lutris:1846): Gtk-WARNING **: 15:35:15.200: Creating a portal monitor failed: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface “org.freedesktop.portal.Inhibit” on object at path /org/freedesktop/portal/desktop
Traceback (most recent call last):
File “/usr/lib/python3.11/site-packages/lutris/”, line 77, in _call_cb
values = obj.call_finish(result)
gi.repository.GLib.GError: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface “org.freedesktop.portal.Settings” on object at path /org/freedesktop/portal/desktop (19)

Is this a python problem? How can I fix this and how can I prevent this from happening again? (This had happened once before and I fixed it by reinstalling lutris but I don’t want to do it again since it’s a bit of a hassle to set everything up again)

I’ve tried removing the dxvk folder in .local/share/lutris/runtime/ but that folder never seemed to reappear when I restarted lutris.

The fix was to reinstall python :expressionless:

sudo pacman -S python