Lutris not working correctly?

Fresh install of EndeavourOs Nvidia (non-free) with the only things installed are wine and Lutris.
However lutris doesn’t seam to be working properly for me :frowning:

Lutris - Witcher Enhanced Edition GOG = no sound driver detected in wine, even when seen still no audio.
Lutris - Crysis GOG plays with sound but is stuttering so badly it takes 4 mins to get to the NVIDIA logo

Installed The Witcher Enhanced Edition GOG with wine only … works perfectly
Will try with Crysis and update accordingly … but any help would be appreciated because getting games to work seams to be not to easy as people say.

I can help you out with Crysis. It’s the stupid videos (the game will work fine). Simply rename them, and while there will be some black screen delay, the menu will eventually appear and it will work correctly with no background video.


There are a bunch of .sfd files, rename them all.

Hey Thanks for the advice, still didn’t fix my issue sadly so I started messing with the setting in Lutris for the game.
For some reason everyone tells me to enable Esync for “better performance” … I disabled it and the game now runs in DX10 with no problems at all.
Not sure why it caused problems when people say it helps :S

Esync is better for performance (than the wine server multiplexing it) but some games can have problems with it. I have found very few that need it disabled.

I patch my kernels (futex_wait_multiple) so I can use Fsync and I rarely need to disable that either. I can think of only one game I have that needs Fsync (and Esync, which it would fall back to) disabled. Bioshock Remastered.