Back to the main site

Lutris not responding when game is open [SOLVED]

Hi!

So i’m having this weird issue where i run the game (Guild Wars 2), and each time the game stutters i get a system message “lutris not responding - force close / wait”…

But the game is obviously open and working, it’s just that, is maybe my system too overzealous what constitutes not responding?

On games easier on the hardware it doesn’t do that, but the system treats each stutter as unresponsive program…

How do i fix that?

I get a simmilar thing when launching minecraft, but there it goes away when the game opens…

It just starts spamming the message constantly and i can’t play the game…

             /////////////                USER@pop-os 
         /////////////////////            ---------------- 
      ///////*767////////////////         OS: Pop!_OS 22.04 LTS x86_64 
    //////7676767676*//////////////       Host: B550M Pro4 
   /////76767//7676767//////////////      Kernel: 6.0.0-9.1-liquorix-amd64 
  /////767676///*76767///////////////     Uptime: 23 hours, 35 mins 
 ///////767676///76767.///7676*///////    Packages: 2250 (dpkg), 33 (flatpak) 
/////////767676//76767///767676////////   Shell: bash 5.1.16 
//////////76767676767////76767/////////   Resolution: 2560x1440 
///////////76767676//////7676//////////   DE: GNOME 42.3.1 
////////////,7676,///////767///////////   WM: Mutter 
/////////////*7676///////76////////////   WM Theme: Pop 
///////////////7676////////////////////   Theme: Pop-dark [GTK2/3] 
 ///////////////7676///767////////////    Icons: Pop [GTK2/3] 
  //////////////////////'////////////     Terminal: gnome-terminal 
   //////.7676767676767676767,//////      CPU: AMD Ryzen 5 5600G with Radeon Gr 
    /////767676767676767676767/////       GPU: AMD ATI 05:00.0 Cezanne 
      ///////////////////////////         Memory: 6021MiB / 15364MiB 
         /////////////////////
             /////////////                                        
                                                                  

Any help would be appreciated!

1 Like

Well, found the solution here:

Wasn’t lutris fault at all, it was just Gnome not being patient enough hehe…
I made it wait longer before it bugs me with the not responding message and now its good.

Here’s the terminal command:

gsettings set org.gnome.mutter check-alive-timeout 10000

This will make it wait 10 seconds before it considers an application unresponsive.
By the way it was behaving, i think it came default set to 1 or 2 seconds, a bit too short if you ask me…

Anyway… Fixed!

1 Like