Lutris not launching Steam/WineSteam applications on dedicated videocard with Optimus laptops

Hello, and first of all, Stryder, thank you for Lutris.

Now onto the issue at hand, I have been toying around with it, and looking at many posts here at the Lutris community. While I do think it IS great, and has quite a few welcome features, I also see a problem with it… I got Lutris from the repos you have at OpenSuSE building System, since I run Fedora… At any rate, I’m running Lutris, and my issue is that for some odd reasons two things seem to not be working correctly: First off, launching games or apps (like Steam or WinSteam) with the dedicated graphics card.

I run an Asus RoG laptop with dedicated nVidia graphics and on-chip crappy Intel HD4600 (good enough for most operations, except gaming). I have set up as a global option to launch games with the primusrun prefix, I even set the prefix manually, and still no dice, any game I launch, inherits the Intel graphics and not the nVidia gaphics. If I launch Lutris with primusrun prefix still launches games (especially wine games) on the Intel graphics.

If I manually launch the games with primusrun prefix (from console or run dialog under my DE), then I am able to run them on the nVidia graphics dedicated graphics card.

I have no experience with primusrun but usually when something works in a shell and not in lutris, it’s usually an issue with the runtime. Try disabling it in the system options of the game.

Also you can see what command is executed by lutris if you launch it from the command line with the -d flag, it will also give you the environment variables used. Please look for anything unusual and report back.

Will try as soon as I get the time, thanks for your reply all the same.

This laptop has been a bit of hit and miss with regards to the dedicated graphics card and Linux, as some games (especially older games) do not like to be changed their render card, such as Quake 4 which I’m “forced” to run on Steam (pfft) for Windows, even though it is an OpenGL application that works very, very well with current hardware (alas, 1080p 4X AA, 16xAF yields 30-ish FPS with the integrated Intel HD4600 with serious dips into lower 20s, upper teens in crowded areas). It is kind of a mess managing games from Steam for Windows and Steam native. Especially if I want to use the Steam Controller :smiling_imp:

By the way, nice site for Lutris, and nice forums software.

Happy New Year, by the way.

I have done some testing today, and indeed. Lutris is not launching applications (Steam) or games on the dedicated graphics card, and even what’s more, games such as Quake 4 even state that they could not initialize Open GL (when disabling the Lutris runtime, and running on the Intel integrated graphics).

Running the version of Steam as installed by lutris in ~/.local/share/lutris/runners/winesteam/prefix/drive_c/Program Files/Steam/steam.exe with the primusrun prefix like this:

cd .local/share/lutris/runners/winesteam/prefix/drive_c/'Program Files'/Steam
primusrun wine WINEPREFIX=winesteam steam.exe

Works as expected. Also, I cannot seem to be able to run winetricks or the joystick control panel from the conextual menu, even though wine is installed system-wide and winetricks is also available system-wide.