Back to the main site

Lutris not finding executable

Hey guys. So, im having issues with lutris in my machine. It can seem to succesfully install any game that runs originally on windows. Last one ive been trying was cod4, which I own on cd. I followed every step on the install and at the end of it, it says it cant find the .exe file in the game install folder

Then when I try to launch the game ofc it doesnt work but also the programm freezes

Using: AMD Vega 8 graphics, Opensuse Leap 15.2

Edit: tried a simpler install to show as an example, in this case, origin launcher:

The executable at path /home/nacho/Games/origin/drive_c/Program Files (x86)/Origin/Origin.exe can’t be found, please check the destination folder.
Some parts of the installation process may have not completed successfully.

Perhaps you could check your script contains valid references to path names and that aliases have been defined to be used on your Linux drive.

This might be related, from Linux_Andy:
The problem with COD installer is that Wine does not update the disc label after swapping discs and the drive letter will still have CoD1 as the label (in Wine config and Explorer) even though CoD2 is in the drive. The installer seems to check the label before it’s contents and that’s why it fails.
The easiest way I have found is to swap discs in wine configuration so that the drive letter stays the same and the label is correct for the second DVD before continuing on.
Probably most installers just check the contents on the swapped disc so these are trouble free.