Back to the main site

Lutris no longer starts on ArchLinux


#1

Hello after updating ArchLinux, Lutris does not start anymore.

Launching lutris from terminal:

[krogan@LINUX ~]$ lutris
Traceback (most recent call last):
File “/usr/bin/lutris”, line 33, in
from lutris.gui.application import Application
ModuleNotFoundError: No module named ‘lutris’


#2

Seems like python can’t find lutris install directory or something. Now I don’t know much python, but reinstall could maybe fix this.


#3

I reinstalled lutris with “yay lutris” and it worked thx


#4

Glad it worked :wink:


#5

Yeah, i had same issue here after lots of python updates.
Reinstalling work for me too.


#6

Same here, and along with a slew of python apps I had to reinstall. On arch also btw.


#7

For future users:

Your package manager might still use an already built package, but you need to rebuild the package.

With yay it’s easy as in this command: yay -S lutris --rebuild


#8

I had the same issue on arch. Reinstalling Lutris (i.e rebuilding the package) worked for me.


#9

Everyone’s using yay now? IS that cause of yaourt no longer being maintained? I suppose I should get on board.