/ Steam Sync - No games found (w/ Public Profile)

I’m a new user of Lutris and I wanted to setup the steam synchronization to access my game library. I’ve followed the recommendations to set my steam profile (+ games details & “private total playtime” unticked) as shown in I’ve got the notifications that the synchronization was running but no steam games shown in the Lutris library…
I’ve tried to :

  • Restart sync by linking my steam account again (also tried to disconnect it beforehand)
  • Set every Steam privacy options to public

Is it supposed to be a slow process ? I’ve got almost 800 games (but I waited already 10min+). None of them are displayed in the Lutris library right now.

If you have any leads, I’m interested !


I don’t think it is exactly supposed to be a slow process, it is certainly not meant to be, but sometimes it is. I only have 93 games currently on Steam, and it still gets slow sometimes. The sync with my Epic Games account gets even slower, and I have less games there. But over 10 minutes could be a little much, TBH…
If you followed the instructions correctly, the problem might be in a slow internet connection at your side, or at the server side, an overwhelmed server, some API bug, or whatever. When this happens to me, I tend to try again later, and give it some time to do its own thing for a while, and repeating yet later if it fails again.

I have hundreds of games and it only takes < 10 seconds. It could be the old “please check the options top right to make sure you’re not only displaying installed games only” thing.

It still doesn’t work. It’s on the web interface that the issue occurs, so i doubt its linked to the display of installed games.
The Lutris App (Debian package, not Flatpak) is working fine, synchronizing my Steam games, so I’ll keep to that.