Back to the main site

Lutris Kodi

I’m want to try out Kodi Lutris addon but it doesn’t seem to work from the zip file because of installation fail. I found this guide to use the GitHub addon to install solbero repo but I don’t know where to find it in addons and after zip file was download and installed. I also tried the Lutris script but nothing appears about Game hub or Lutris anywhere.

My Kodi version is 18.8.0 Git 20200727-45686bddb1

I’m on Manjaro KDE 64 bit

I also use the PPA Kodi. Didn’t know about this addon, but it installs and works ok from the repo version.

  1. Download solbero .zip
  2. Start Kodi. Click config cog. Navigate to System -> Add-Ons -> Check “unknown sources” to allow
  3. Go back to config main menu. Navigate into Add-Ons. Click “install from zip file”. Browse to the solbero .zip
  4. Go back to top level config options. Click Add-Ons, click “Install from repository” Select “solbero’s Kodi add-on repository”. Navigate to “Game Add-ons” -> “Game Providers”, click on “Lutris” to install.

…works fine. I’m also running a .deb distro, so unless there’s something stopping python working properly, it should be ok.

Could you provide a link to your solbero zip file? mine fails to install due to an invalid structure

I installed from Github browser but the addon doesn’t appear anywhere

I only see Advanced MAME Launcher

From your original link, it jumps to solbero’s readme.md scroll down and click the download on step #2

@XDqAtG5A8g I mentioned that zip fails to sinatll

As I said, it worked for me. All the solbero zip does is installs a new repository link - it really couldn’t be more basic. You just select the add-on out of it.

If you’re 100% sure there is no extra repo, you either have a download problem (check zip isnt corrupt) or a conflict, in which case you’ll need pick through your Kodi logs and take to the Kodi forums.

Will do that, TY