Back to the main site

Lutris is Slow to Launch Unless it is Run by Root

Hello all. I am using archlinux and every time I run Lutris as a user, it takes around 30 seconds to launch. I am using an nvme ssd and everything else on my pc launches very quickly so this is out of the ordinary. When I run lutris as root, it starts instantly. Has anyone else had this problem? My debug output doesn’t show anything interesting.

INFO 2020-05-26 09:25:40,422 [application.do_command_line:245]:Running Lutris 0.5.6
INFO 2020-05-26 09:25:40,422 [startup.check_driver:62]:Using X.Org
INFO 2020-05-26 09:25:40,422 [startup.check_driver:64]:Running Mesa driver 20.0.7 on AMD Radeon RX 5700 (NAVI10, DRM 3.36.0, 5.6.14-arch1-1, LLVM 10.0.0) (0x731f)
INFO 2020-05-26 09:25:40,422 [startup.check_driver:77]:GPU: 1002:731F 1462:3811 using amdgpu drivers
INFO 2020-05-26 09:25:40,472 [startup.check_vulkan:132]:Vulkan is supported
INFO 2020-05-26 09:25:40,473 [dxvk.get_dxvk_versions:22]:Updating DXVK versions
DEBUG 2020-05-26 09:25:40,678 [http.get:65]:GET https://lutris.net/api/runtime

If anyone has had this or a similar problem and has found a fix, advice would be greatly appreciated.

When running Lutris in debug mode, do you get more output then?

lutris -d

BTW: Running as root is not advised, but reading your issue I gather you already know that. :slight_smile:

Yes, I already knew that lol. I’m fully aware that most apps should not be run as sudo but I figured I’d just try doing that to see if it made a difference. That, there, what I put in my original post was the output I got from debug mode. Nothing but that showed up. Is there some log file I’m supposed to look for or is that correct?