Back to the main site

Lutris is opening very slow


#1

Hello,

I recently installed Lutris 0.4.19 on my system, but for some reason, it takes forever to open. On average, it takes about 1 - 2 minutes to open. My main system is running Manjaro, but I’ve also tried running Lutris on Ubuntu too and the issue seems to still be there. Does anyone know what could be causing this?

I ran lutris in debug mode to see if anything would come up, and all I got was a missing directory error for a DXVK file. I don’t think this would be causing my problem, but I’m not sure.

Here’s the error:

ERROR 2018-09-26 09:28:27,815 [dxvk]:[Errno 2] No such file or directory: '/home/chodetode/.local/share/lutris/runtime/dxvk/dxvk_versions.json'


#2

I wonder if the dxvk download is timing out. Maybe try unchecking any instances of dxvk in your game scripts and relaunch Lutris.


#3

#4

I have exactly the same problem with the delay in launching Lutris and i get no errors in debug mode. I think the DXVK error that the OP gets is indeed irrelevant to the launch issue. I get similar delays any time i try to use sth in lutris that requires a window to pop up (for example the wine version manager). And still no error messages in debug mode. The issue appeared with the latest lutris update. Before it was fine. And all games that worked before the latest update still work fine.

I am on Mint cinnamon btw…Could it be an issue with the desktop environment?

EDIT: And using the 0.4.20 version as well


#5

Not sure if it would be the desktop environment, but I just tested Lutris on Arch/XFCE with no issue’s, and a VM of Peppermint OS (really nice BTW if anyone’s interested). I think it uses LXDE? No slow starts there either. Compositors enabled on both. Using the Battle.net script worked pretty good, though I did notice the initial launch was slow until the proper DXVK folder was created and downloaded. I didn’t have to manually create it either. It must’ve got fixed in v4.20. Didn’t even install vulkan or set ulimits for esync either (on the VM that is).

Now Im yammering on!!!


#6

On 4.21 i still have the same issue of slow start. On top of that 4.21 cannot see DXVK any more either even though it was installed and 4.20 worked fine. 4.21 seemed completely broken for me when freshly upgraded. I had to delete all DXVK versions and let them be reinstalled to make it work properly again. Things seems to work now but the slow start remains. Only debug messages i get are these but i doubt they have anything to do with the slowdown as they appear only after the application seems to wake up.

DEBUG 2018-10-21 16:25:11,628 [http]:GET htt ps://lutris.net/api/runtime
INFO 2018-10-21 16:26:11,821 [lutriswindow]:Connected to lutris.net as turin231
DEBUG 2018-10-21 16:26:11,822 [api]:Fetching game library
DEBUG 2018-10-21 16:26:11,823 [http]:GET https://lutris.net/api/games/library/turin231
DEBUG 2018-10-21 16:26:11,911 [steam]:Watching Steam folder /home/turin/.steam/steam/steamapps
DEBUG 2018-10-21 16:26:11,912 [steam]:Watching Steam folder /mnt/cf6129df-babc-49c6-98ee-6d1f4e20928b/SteamLib/steamapps


#7

I had the same issue with slow start up (Arch x86_64, xfce) and it turned out the http gets were taking a long time to fail on ipv6 before falling back to ipv4. I disabled ipv6 and it launches right away now.


#8

Similar issue, on arch also. Lutris needs a minute to start but lutris -d doesn’t show an error or warning it just takes longer to start than firefox or steam.


#9

I didn’t see any errors with lutris -d either. The process just blocked on the http get until some internal timeout happened for ipv6, then it went through on ipv4. No errors or trace messages.

You can test if it’s ipv6 (without permanently disabling it) by running:

sudo sh -c ‘echo 1 > /proc/sys/net/ipv6/conf/all/disable_ipv6’

If Lutris comes up right away for you after running that it’s an ipv6 issue.


#10

It does seem to be the ipv6 is taking longer to respond, lutris launched almost instantly with it disabled.