Back to the main site

Lutris installer gets stuck when installing Battle net

In an attempt to install Battle net(both battle net installer and overwatch installer), Lutris gets stuck during installation.

The installation itself is fine. Battle net launches and I can install overwatch form there. The issue is that Lutris won’t exit out of the launcher. It gets stuck on this page.
https://drive.google.com/file/d/1zopO_OFBh1pJIeVl5tkQ-j_elgOz8vKU/view?usp=sharing

It gets stuck at this command line

03fc:fixme:dxgi:d3d11_swapchain_Present1 Ignored present parameters 0x71c2e0.

It stays here for hours until the power is shut down, or if I cancel the installation, which fails the installation.

The full log can be found below.

I have followed all of the troubleshooting steps provided on the lutris. net GitHub page. I have all the necessary Vulkan driver. I cannot figure out what when wrong. Any help with this installation would be greatly appreciated.

Update on the log


Spoiler alert.
More ```
03fc:fixme:dxgi:d3d11_swapchain_Present1 Ignored present parameters 0x71c2e0.

update. I am now getting an addtional error line called

0364:err:d3d:wined3d_context_gl_reacquire Acquired context 0x15c73dc0 instead of 0x4be76a0.

When I launched overwatch from battle net. I do not see the shader compiling notification on the bottom left but the game is running and after some time, runs really well, almost as good as from windows.

Hello,

I had the same error in Pop OS 20.10. I found a Reddit thread where they advise closing the Battlenet windows in order to let Lutris complete the installation. Worked for me :slightly_smiling_face:

2 Likes

Just want to say that after a couple of hours looking for solutions, this is the one that worked for me. Thanks a ton!