Lutris hangs on "fetching..." [SOLVED]

Howdy. New Lutris user here, and I’m trying to install League of Legends on a Gentoo box.

I’m sure there are going to be a mess of issues I’m going to run into, flags to be enabled, kernel rebuilt, etc before I get this going, but firstly I can’t seem to even download LoL from

Lutris is installed, and it runs. I go to “…/league-of-legends” click “Install” next to the OpenGL version; the dialog box pops up asking me to confirm the OpenGL version and installation directory; however, after confirming this it hangs on “Fetching …/” and shows 0.00Mb out of 0.00Mb (0.00Mb/s), 0 seconds remaining.

Buh? What am I screwing up, here? Can I get some kind of debug output on this to see where it’s hanging?

I’m able to navigate to “…/” in my browser just fine to download it… Could I just toss this into the appropriate folder and have Lutris recognize it? Or if someone could point me towards some documentation on how to install games via Lutris I’m not averse to rtfm.

Much love.

omfg “Sorry, new users can only put 2 links in a post.” D:

I was installing Lutris through portage w/ an overlay (I’m on Gentoo) and forgot to add lutris ~amd64 to package.accept_keywords, so it was installing an old version of Lutris from the main repository and I didn’t notice. Neato. Top marked [SOLVED]