Lutris Game Banner is gray ( no banner)

Hi, do you have Lutris 5.10 working fine with game banners?

My Lutris version 0.5.10 does not display game banners, only gray. The previous version was displaying the banners but when I upgrade to 5.10 the preveious banner are still there but when I add new games, the banner is only gray. I have tried downgrading to the previous version (I can’t remember the version) and the banner are displayed again but when I upgrade again to 5.10, any new game added only has gray banner. I have tried reinstalling lutris many times but I can’t solve the problem. :slight_smile:

Here are my system details:
OS: Pop!_OS 20.04 LTS x86_64
Host: 81BG Lenovo ideapad 320-15IKB
Kernel: 5.10.67-xanmod1
Resolution: 1920x1080
WM: Mutter
WM Theme: Pop
CPU: Intel i5-8250U (8) @ 3.400GHz
GPU: Intel UHD Graphics 620
Memory: 2414MiB / 3711MiB

More details here: Ubuntu Pastebin

1 Like

I had to synchronize my Steam library to my lutris account, I do agree it should be not related but at the moment it is like that.

It didn’t work, but your suggestion gave me an idea. My games are usually installed manually. What I did is go to the Lutris website, search for the game and click “add to my library” then I click sync in my Lutris Client. After that, the missing banner for those installed games showed up. Problem solved!

Thank you for helping. I hope that they will fix it so we don’t have to manually do that. But for now that work around is working.