Back to the main site

LUTRIS ERROR Not enough memory! Unarc.dll

Anytime I tried to install a fitgirl repack game thru Lutris in Z:\Games\Age of Empires - Definitive Edition I get the following error ISdone.dll An error occured while unpacking: Not enough memory! Unarc.dll returned an error code: -5 ERROR: archieve data corrupted (decompression fails)

How do install the game? seems like no matter what file I select in Z:/ I get the same error.

1 Like

After a bit of a headache I found the problem. It turns out Lutris default wine version (lutris-fshack.*) has this problem, to fix this:

  1. Be sure you have an updated system wine version - version 7.0 by the time I write this. Search for a stable and updated repo for your distribution
  2. Go to Lutris > Select your game > Configure (Bottom arrow menu next to Play) > Runner Options > Select “Wine (7.0)” intead of “lutris-fshack…” > Click “Save”
  3. Run your EXE inside wine prefix (Bottom arrow menu next to the wine button) and run your exe
  4. At this point it **should** run, complete and close, but that’s not all, it will most certainly crash if you try to run the game
  5. Go back to Configure > Runner Options, select back the default runner lutris-fshack.* and save
  6. Run your game (please see notes at this point)

Notes:

  • This sketchy procedure was found after hours of tweaking parameters, I might have installed some components through winetricks that helped with this workaround but anyway, I had the problem with all these components and fixed it with this method
  • Sometimes wineserver gets stuck/freezes/stops, if at step 6) nothing happens, try rebooting your computer before reinstalling the whole game