Back to the main site

Lutris Don't lauch

Hello, can anyone help me ?

After installing lutris, I tried to open it many times but it didn’t work. I tried killing the task, restarting the computer but it still didn’t work.

Parrot Os Home
Intel i5-8300H
Gtx 1050
Dell G5-5587
Log:

I’m sorry for bad english.

AttributeError: type object 'TreeModelSort' has no attribute 'sort_new_with_model'

This is a bug that was fixed in Lutris 0.5.5, which was released in March 2020. You’re running Lutris 0.5.1. If you upgrade to the latest version then it will work.

i’m tried “sudo apt-get update” but it does not display any new updates

Did you install the Lutris PPA or are you using the version that comes with your distribution?

I don’t know much about Parrot OS, but it looks like it’s Debian based. Try the Debian download instructions here: https://lutris.net/downloads/

:((( I installed lutris the way listed for debian

Just to be sure, apt-get update refreshes your package list, while apt-get upgrade will actually upgrade packages.

Can I see what your /etc/apt/sources.list.d/lutris.list file looks like?