Lutris doesn't install any game on Manjaro x64

Hello everyone,

So I am new to Lutris and I tried to install some games, but none of them actually installs, the setup process is very quick and doesn’t install anything, it just creates the Wine Bottle but with no game in it. I have checked both Program Files and Program Files (x86) for three games until now.

I have tried to install:

  • World of Tanks
  • GTA San Andreas (from ISO)
  • League of Legends

All three games completed with the same results, completed very fast but then there was no game in the Wine bottle and they show the same notification:
The file path/client.exe could not be found

I tried on two different devices, one PC and one Laptop with the following configurations:

  • Manjaro x64 KDE
  • tried Kernels: 4.14, 4.16, 4.17
  • up to date drivers
  • Wine, Wine Staging, Wine Staging Nine

And here is the Terminal output:

INFO     2018-06-08 14:13:25,382 [lutriswindow]:Connected to as ....
INFO     2018-06-08 14:13:33,821 [lutriswindow]:Installing None
INFO     2018-06-08 14:13:40,843 [interpreter]:Downloading file 1 of 1
INFO     2018-06-08 14:14:02,127 [wine]:win64 Prefix created in /home/kalyn/Games/league-of-legends
wine client error:0: version mismatch 549/554.
INFO     2018-06-08 14:14:17,501 [runner]:Runtime disabled by system configuration
Gtk-Message: 14:14:17.581: GtkDialog mapped without a transient parent. This is discouraged.

Thank you in advance!

I have all the dependencies installed, but I cannot find any reference on google about bashrc linked to my error

Hi , probably related to you can try and install next branch .

Thank you for your reply, my problem might be linked to that issue but unfortunatelly I only have two options, lutris-bin and lutris-git, I tried with both and the behaviour is the same.

I reinstalled all wine dependencies from this link and restarted the laptop then I tried to reinstall all the 3 games, GTA SA (from ISO) and League of Legends have the same behaviours, World of Tanks DXVK however now installs and updates, but I cannot get past the launcher, the game just quits, tried many methods found online and none of them worked unfortunately, for now I think I’ll call it a day and move on until I can find a proper fix or the Lutris updates fixing this

you can give a shot to next branch :
extract it than to try out lol for example
download the install script at
python lutris-next/bin/lutris -i league-of-legends-windows-dx9.json

Thank you very much for your help. Lutris Next doesn’t work on my system because it throws an error stating that the GNOME environment is not present.

However, as it turns out, the GTA San Andreas installer was not working because of the script used, League of Legends is the same story, World of Tanks for some reason just doesn’t work on my system even if I installed it and DXVK manually and I was not able until this moment to find what is wrong with it.

For San Andreas I wrote another install script wich now works and installs the DVD version of the game with no problems, so that is problem solved, League of Legends installers are restricted and sadly I cannot make a script for it and for World of Tanks I just need to find why it is not working in the first place, but the problems are not with Lutris itself

No, it should only display that as a warning, not crash.

After displaying that warning in the terminal Lutris doesn’t appear and it just stays like that. Now I am using Lutris-bin from the Arch repos and it works well, my problem was from the installers, also I think that I am missing some dependencies for WoT and that is why it doesn’t work for the moment, I will continue to look into fixing it when I have time