Back to the main site

Lutris doesn't detect installed Steam games anymore

I had them imported before, then I re-synced through “Lutris -> Import games” and they all vanished. The games are all (not installed, too) still under “All runners” but not under “Steam” and “Winesteam” and all listed as not installed. Running Lutris from terminal doesn’t give any related errors. I get a warning though: “This version of Gtk doesn’t support set_option_context_summary”

I’m on Ubuntu 16.04 and got Lutris from the OpenSuse build service.

Nobody? I’m using Lutris 0.4.18. It makes the program unusable, because I’m not going to set up all games by myself.

The game yml config files are all still there btw. But none show up.

If I try to install an already installed Steam game, it gets stuck on “Installing game data” while Steam does nothing, of course.

Installing a yet uninstalled game starts the download on Steam, but when it finishes, Lutris never notices, also getting stuck on “Installing game data”.

Edit: Ok, so I launched lutris -d and it says “[steam]:Watching Steam folder /home/username/.steam/steamapps” but that’s not where my games are. They’re all in a different Steam library. How do I change that?

That’s a setting in the Steam client…Right-click your Steam runner on the left in Lutris, run it. Go into its library folder options, and pick the right folder. Not on the right machine right now, so I can’t get more specific.

I already have my actual path set up in Steam as my default one. Lutris also used to work before so I don’t think it’s because of Steam.

I just completely re-installed Winesteam though and after telling Lutris to import the games from it, they re-appeared. But the games from my native Steam installation are still missing. Also, clicking the sync button for that doesn’t show any reaction on the CLI window, despite lutris -d.

Nothing has changed with 0.5. It doesn’t show any games in the “import games” menu.

I also get these errors upon opening Lutris:

2019-02-01 21:03:37,612: Failed to get runtimes: Unavailable url https://lutris.net/api/runtime: HTTP Error 502: Bad Gateway
2019-02-01 21:03:37,625: Unable to get games from API: Unavailable url https://lutris.net/api/games: HTTP Error 502: Bad Gateway
2019-02-01 21:03:37,675: Error while completing task <function sync_from_remote at 0x7f8c075fd6a8>: Unavailable url https://lutris.net/api/games/library/Username: HTTP Error 502: Bad Gateway
<class 'lutris.util.http.HTTPError'> Unavailable url https://lutris.net/api/games/library/Username: HTTP Error 502: Bad Gateway
  File "/usr/lib/python3/dist-packages/lutris/util/jobs.py", line 30, in target
	result = self.function(*args, **kwargs)
  File "/usr/lib/python3/dist-packages/lutris/sync.py", line 98, in sync_from_remote
	remote_library = api.get_library()
  File "/usr/lib/python3/dist-packages/lutris/api.py", line 83, in get_library
	response = request.get()
  File "/usr/lib/python3/dist-packages/lutris/util/http.py", line 72, in get
	raise HTTPError("Unavailable url %s: %s" % (self.url, error))
2019-02-01 21:03:38,028: Failed to synchrone library: Unavailable url https://lutris.net/api/games/library/Username: HTTP Error 502: Bad Gateway

And this, whenever I click on the “Steam” runner in the left pane:

Gtk-CRITICAL **: gtk_tree_model_sort_convert_iter_to_child_iter: assertion 'valid == TRUE' failed
Gtk-CRITICAL **: gtk_tree_model_filter_real_unref_node: assertion 'filter->priv->stamp == iter->stamp' failed
Gtk-CRITICAL **: gtk_tree_model_sort_real_unref_node: assertion 'elt->ref_count > 0' failed

Ubuntu 18.04

I have the same problem. When I run lutris --list-steam-folders there was the ~/.local/share/Steam/SteamApps folder, but this folder was empty. I have added a symlink to the ~/.local/share/Steam/steamapps (lowercase steamapps) and now the games are displayed correctly.

I don’t think this solution is good, but it works.

1 Like

Manjaro same. Cannot find manual added steam folder locally or on external drives.

I don’t think that’s a good idea to post on such an old thread, but this is happening to me also. It was working fine just a few weeks ago, then I reinstalled Manjaro to start fresh, but now Lutris isn’t finding my Installed Steam games. Weird thing is, that neither is Gamehub!?! My Steam profile remains the same, I haven’t touch it.
Steam is installed on a ext4 partition, the games are installed on a different disk, but also ext4.
This looks like a fund weekend project to trouble shoot, maybe something to do with permissions? I’m mounting the hard drives with fstab, and “default” is the only mount option. Steam works like a charm with those drives.
Other thing, I can “install” the already installed steam games on Lutris, and they just appear as installed, no installation process.
I hope this helps
-------------------------- LAST MINUTE UPDATE YO!----------------------
I tried something new and different… I installed a game on the default installation location on home, and Lutris did find it! (Gamehub too!!!) so… this means… SOMETHING!
I’ll keep bashing my head until finding a solution, Man! These linux trouble shooting surely are fun!
--------------------New Edit ------------------------------
It’s 00:51 AM, and I’m tired, I tried changing the boot options on fstab, from default to “user,exec,dev,suid,rw,async”, it made no difference. I also disabled those hard drives on fstab and let KDE mount the drives, again, no difference.
Lastly, I tried making a link to the “problematic” drivers on the same folder where steam is, but… yeah… no dice.
--------------------Even Newer Edit ----------------------
So I did the last bastion of troubleshooting, I reformatted and reinstalled the OS. The problem continues. Somehow it’s even worst! Lutris can’t even detect the locally installed games (on the root partition). I’ll keep bashing my head, but at this point, it’s starting to hurt.
-------------- … this is getting boring-------------------
Lutris version 5.8.3 does detect the games installed on the root folder, it’s lutris version 5.8.4 that doesn’t. I guess that I’ll try a flatpak, or snap.
Another thing I can try is installing a different distro, but sounds like an idiotic idea.
I also tried changing the permissions of the HDD, and the ownership, my user name with my user name group is the owner of every drive on my pc, and the permissions were set to 777, and once I notices nothing had changed, I revert it to 755.
There are some users on github with the same problem, but so far, no solution, well… one guy made a scrip to import the games?!? something like that… but that’s not a solution for me. I’ll try something else… to install a linux game from the official manjaro repos, I should find it. Nope, it didn’t… I guess I’ll have to manually integrate the games. THIS SUCKS!
-------------------------Last edit--------------------------
Found the reason as to why lutris isn’t detecting the games installed on different drives; it’s because Steam is changing the installation folder manager. So the solution to this problem is to have patience and wait for the devs to incorporate the new “libraryfolders.vdf”. In theory, if we could find a way to create the old file, it should work, since there aren’t too many users affected with this problem, I asume the old file still works.
The same file is responsible for Gamehub Steam Integration problem too.
Cheers and have a good day! :wink:

Greetings, It’s a me again, and no, the issue is not yet fixed, And the only mention of this issue on github was deleted, so it might never be fixed. Sad face…
Cheers