Back to the main site

Lutris does not start

I installed lutris through sudo pacman -S lutris
Running Manjaro
It seems that I cannot open lutris at all.
The output is the same for both lutris --submit-issue and lutris -d:

Traceback (most recent call last):
File “/usr/bin/lutris”, line 52, in
from lutris.gui.application import Application # pylint: disable=no-name-in-module
ModuleNotFoundError: No module named ‘lutris’

Would greatly appreciate any assistance, and I have reinstalled lutris multiple times.

Yeah, something isn’t right there. First of all, is your distro up to date?

pacman -Syu

In Manjaro, Lutris should be “community/lutris 0.5.10.1-2” if you installed it with pacman -S. Installing such a package is pretty straight forward, it should have pulled in its dependencies. This could be a broken python setup on your system.

I have since then found an alternative, but I can assure you my system files were up to date and I run pacman -Syu regularly (and of course it was the first thing I tried)

I find it incredibly weird that I was able to pull lutris with pacman -S and I got could find its files, and it was accessible through application launcher. It just seemed like I installed an empty shell of Lutris.