Lutris does not open

I installed Lutris and it doesn’t open. There weren’t any errors. Nothing happens when I try to run it. I use linux since two days (manjaro), so I it’s possible I did something wrong.

Hum. If you’ve only been using Linux for two days, I suspect by “no errors” you mean “no error message windows” (correct me if I’m wrong). Unlike Windows, when you run a Linux program in terminal, it’ll print out additional information like errors to the console (well, almost all of them do).
If you don’t know how to run Lutris from terminal, most likely you only need to open a terminal emulator window (shouldn’t be hard to find) and type lutris into the prompt (if Lutris was installed globally).

I did run Lutris from terminal and this is what showed up.


@Crimsoon Did you install wine before you installed Lutris? Yesterday after about a year trying to install different Linux distros I finally installed Linux Mint 19.1. I assume since the instructions on Lutris web site have you install Lutris using the Arch-based package manager I would uninstall Lutris and Wine (if you already have Wine installed). Then try again installing Wine globally first then Lutris.

I did instal wine before. Both, wine and lutris, were installed globally.

@Crimsoon I am out of ideas. I installed Wine first then Lutris yesterday. Lutris will load up for me, but I can’t use it. The required Linux Nvidia drivers don’t support my graphics card. Did you use Manjaro’s package manager to install Wine and Lutris, or did you install both programs without using Marjaro’s package manager?

I used software manager. I also unpacked .tar to check if files are where they’re suposed to be. They are. I also tried to install lutris with pacman but it didn’t work.

I don’t have any other ideas on what could be wrong. Who is the manufacturer of your graphics card? It might help if you would list your system specs.

I don’t think it matters because when I run it in terminal it says there is file missing.

Well, I guess you know what is wrong with your install of Lutris; you need to install the missing file.

But the file is where it’s suposed to be.

Regarding wine: Lutris isn’t run by Wine, and it can perfectly run Windows games without a global Wine install (relying on internally downloaded Wine versions). So the Wine thing should be irrelevant.

Are you talking about the error message? Because it refers not to ‘file’ but to ‘module’ (the difference being different way of access, basically). I cannot say for sure, but perhaps you’re not running Lutris using the correct version of Python? It probably can’t find the module because it’s looking for it in a different folder altogether.