Back to the main site

Lutris does not open after crash

I use manjaro linux, my linux worked perfectly until this weekend, when it crashed and never opened!!!
I’ve tried everything I found in the forums and there’s no solution, seriously, someone can help me, I really like lutris it saves my life, I can’t do without it working.

 2021-06-07 Preformatted text 14:52:28,861: The Retroarch config in <DirEntry 'core_info.cache'> could not be read because of character encoding issues
    Traceback (most recent call last):
      File "/usr/bin/lutris", line 52, in <module>
        from lutris.gui.application import Application  # pylint: disable=no-name-in-module
      File "/usr/lib/python3.9/site-packages/lutris/gui/application.py", line 53, in <module>
        from .lutriswindow import LutrisWindow
      File "/usr/lib/python3.9/site-packages/lutris/gui/lutriswindow.py", line 26, in <module>
        from lutris.gui.widgets.sidebar import LutrisSidebar
      File "/usr/lib/python3.9/site-packages/lutris/gui/widgets/sidebar.py", line 6, in <module>
        from lutris import platforms, runners, services
      File "/usr/lib/python3.9/site-packages/lutris/platforms.py", line 19, in <module>
        _init_platforms()
      File "/usr/lib/python3.9/site-packages/lutris/platforms.py", line 14, in _init_platforms
        runner = runners.import_runner(runner_name)()
      File "/usr/lib/python3.9/site-packages/lutris/runners/__init__.py", line 79, in import_runner
        runner_module = get_runner_module(runner_name)
      File "/usr/lib/python3.9/site-packages/lutris/runners/__init__.py", line 71, in get_runner_module
        return __import__("lutris.runners.%s" % runner_name, globals(), locals(), [runner_name], 0)
      File "/usr/lib/python3.9/site-packages/lutris/runners/libretro.py", line 47, in <module>
        if "categories" in core_config.keys() and "Emulator" in core_config["categories"]:
      File "/usr/lib/python3.9/site-packages/lutris/util/libretro.py", line 80, in keys
        return list([key for (key, _value) in self.config])
    TypeError: 'NoneType' object is not iterable

Here are some of the solutions I’ve tried:

mv ~/.config/lutris ~/.config/lutris_bak

and

wget https://cdn.discordapp.com/attachments/538903130704838656/796102070825779250/dxvk_versions.json -P $HOME/.local/share/lutris/runtime/dxvk

This is related to RetroArch (a libretro front end for various emulators). Apparently newer versions create that core_info.cache and Lutris barfs on it.

What do you actually use in Lutris? Wine runners don’t use that, I don’t have it installed on my system. If you’re not using it, you could probably “pacman -R” those RetroArch packages and remove the RetroArch runner from Lutris?

I’m not familiar with it, but other things to try would be to find and delete that core_info.cache file

Ahh, look what I found:

"guyfeefungal
Op ·
1d

I deleted ~/.local/share/lutris/runners/retroarch

I feel kinda stupid I didn’t do this earlier, instead I was looking for every cfg and in between whatever."

I’m going to do that and delete this folder as I can’t find this core-info.cache at all.
What I did yesterday to resolve the situation was to install a lutris from the AUR which was available from the package installer and now it works again, as everything is ok I won’t risk removing or anything, but as soon as possible I will install lutris from the official repository and see if the mass remover solution worked.

Hey, as long as you’re happy and it’s not broken (I tried lutris-git once a while back, with poor results). This issue is probably fixed there.

You should probably wait for the next Lutris release before going back to the official distro package (or Arch PKGBUILD, as Manjaro will probably not have it right away)

Now, I just noticed an embarrassingly stupid typo on my part in my previous post.

I’m not sure it matters now, but I meant to say “Wine runners DON’T use that” (RetroArch)