Back to the main site

Lutris does not launch

Because of this issue, I can’t use lutris --submit-issue.

While I had Lutris open, I attempted to import a newly installed Steam game. From there, Lutris crashed. I then attempted to re-open Lutris, but it didn’t launch.

I tried launching through the terminal using lutris -d and it throws the following error:

Lutris error on Pastebin

I’m not in a good mood and am likely to jump ship back to Windows if I can’t get this fixed. Because Lutris doesn’t launch, lutris --submit-issue doesn’t work either.

Here are my system’s specifications:

  • Ubuntu 20.04 LTS
  • Ubuntu Gnome Desktop Environment
  • LightDM Window Manager
  • NVIDIA driver 440 for an RTX 2060

I’ve managed to solve the issue on my own (at least for now - I don’t know how permanent the fix will be). I followed instructions which can be found here.

I created a file in home/.config/lutris (as I didn’t already have it for whatever reason) and called it lutris.conf . Inside that file, I added the lines:

[lutris]

migration_version = 7

Then saved the file in the aforementioned directory. I tried launching again, and Lutris started back up again.

That’s strange, it looks like something got messed up between the database and your config file. I wonder if your config file got deleted somehow, since it should have existed already.

That’s what I was wondering too, but I haven’t any ideas as to why it would have happened, besides marking all upgraded packages (and installing them) in Synaptic Package Manager.