LUTRIS Deleted my whole partition data

im having a very bad issue with my hdd im using debian stretch 9.3 stable and today i wanted to install lutris then i installed fortnite through it but the download didn’t completed so i entered the lutris interface then select delete the game after the process freezed i closed it then i entered my 375gb ntfs partition which was fortnite and my whole data in it and find out that all of the data had gone but the partition still there empty so lutris deleted my partition data instead of deleting just the game is it possible to recover all of my iso images,vm’s,movies,photos,etc?! please help me its really important data

Why did you install wineprefix in directly drive ? Just create folder and install…

Sorry to say it but I dont think its possible with ntfs. It can be possible but U cant save all of your files.

When attempting to install/delete something, Lutris always makes mention of the folder in question. If what you did was install Fortnite in the equivalent of “C:”, I’m sorry, but there’s not much to be done. Lutris explicitly states “I will delete folder named C:, do you want to proceed?” (of course with the folder having whatever linux name you have)

Don’t mount ur partition again till u finished recovering (further usage of the partition will risk overwriting ur data), Probably ur best bet is to use photorec, I think its in the Debian repo.


thx dude you really saved me i used testdisk to undelete the data and thankfully i recovered almost 93% of my data so i appreciate your help thx


Glad it worked out :slight_smile:

I’m glad you got your files back!

This looks like a very serious issue and it would be horrible if that happened because of a bug in Lutris. I think it’s good to have more information about this case so it can be fixed.
Did you change any settings in Lutris when you tried to install the game? Do you know what path you installed the game in?

And I think it would be useful if you backup your data to a second drive when possible, so if this happens again you don’t loose anything.

I looked at the installer , indeed it has a flaw
exe: drive_c/Program Files (x86)/Epic Games/Launcher/Portal/Binaries/Win32/EpicGamesLauncher.exe

basically the game path is hard coded to the wrong place and if u’re unlucky enough and install it on a windows partition op case will happen.
I’ll suggest the change on the game page.

Well tested it, I’m probably wrong , the game installed at the correct path, and remove worked correctly.

That doesn’t seem to be the issue.

The full command is

arch: win64
args: -SkipBuildPatchPrereq
exe: drive_c/Program Files (x86)/Epic Games/Launcher/Portal/Binaries/Win32/EpicGamesLauncher.exe
prefix: $GAMEDIR

which falls under the prefix $GAMEDIR, which will have the default name (fortnite). More specifically ~/Games/fortnite. If the original poster didn’t change the default paths, the game would have been installed in that folder and its deletion would only delete that one folder.

EDIT: Since the game doesn’t work because of “higher reasons”, what I’d suggest is that the game didn’t try install AT ALL and only showed some error screen like “Game unsupported on Linux because of its AntiCheat technology”

1 Like

Yep, my bad ^^ maybe the op installed it at the root of the partition that would explain it i guess

Maybe lutris should just forbid overwriting prefixes instead of issuing a warning, I cant think of a use case where actually overwriting the pfx is necessary

Oh Please remember that “C:” in wine installs are almost always in your $WINEPREFIX and I, personally avoid that like the plague.

My root FS ("/…" in linux) is “Z:…” so my games get always installed in /home/nuraan/Games as “Z:\home\Nuraan\Games…”