Back to the main site

Lutris Config won't load


#1

I can’t get the lutris game config to load
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/lutris/gui/lutriswindow.py”, line 708, in on_edit_game_configuration
dialog = EditGameConfigDialog(self, game, on_dialog_saved)
File “/usr/lib/python3/dist-packages/lutris/gui/config_dialogs.py”, line 471, in init
self.build_tabs(‘game’)
File “/usr/lib/python3/dist-packages/lutris/gui/config_dialogs.py”, line 39, in build_tabs
self._build_runner_tab(config_level)
File “/usr/lib/python3/dist-packages/lutris/gui/config_dialogs.py”, line 239, in _build_runner_tab
self.runner_box = RunnerBox(self.lutris_config)
File “/usr/lib/python3/dist-packages/lutris/gui/config_boxes.py”, line 547, in init
self.generate_widgets(‘runner’)
File “/usr/lib/python3/dist-packages/lutris/gui/config_boxes.py”, line 65, in generate_widgets
option[‘choices’] = option’choices’
File “/usr/lib/python3/dist-packages/lutris/util/display.py”, line 66, in get_unique_resolutions
return sorted(set(get_resolutions()), key=lambda x: int(x.split(‘x’)[0]), reverse=True)
File “/usr/lib/python3/dist-packages/lutris/util/display.py”, line 66, in
return sorted(set(get_resolutions()), key=lambda x: int(x.split(‘x’)[0]), reverse=True)
ValueError: invalid literal for int() with base 10: ‘v:’

i get this when trying to open it


#2

This is fixed in git, it’s an issue with parsing the output of Xrandr when DisplayPort outputs are available.

Since this seems to be somewhat common, we’ll release 0.4.17 with the fix shortly.