Back to the main site

Lutris Cannot Find DXVK

I start lutris in a terminal, try to launch a game, and get the below messages. Note that I have several versions locally installed by lutris, including v1.7L-84bb768 noted below. They’re installed in location: ~/.local/share/lutris/runtime/dxvk

DXVK v1.7L-84bb768 is not available yet, downloading…

Failed to get url Request to failed: HTTP Error 404: Not Found

Failed to download DXVK v1.7L-84bb768

I don’t think that one exists… mine got changed to that somehow by Lutris (didn’t realize it because I wasn’t showing those Advanced fields) and it broke pretty much everything.

Try the 1.7.2L-whatever or the current 1.7.3L

P.S. I don’t know if this is relevant to your situation, but there’s a dxvk_versions.json file that is sometimes out of whack. One example of such a discussion thread, with a command to download it. However, it’s from someone’s discord attachment so I couldn’t say if the command is still valid.

Thanks! Downloading that new json file worked perfectly. After I started up Lutris, it immediately downloaded 1.7.3L, and everything works correctly.

This caused me to take a look at mine. I was wondering why I wasn’t getting new DXVK versions, still with 1.7.3L as the current (default). My dxvk_versions.json had a modified timestamp of Jan 26.

I renamed mine (in case it wouldn’t download) then started Lutris, and it downloaded a new one and downloaded DXVK 1.8.1L which now shows up in the list as default.

I’m glad, because the bundled vkd3d-proton d3d12.dll now corrects screen space reflection corruption in Cyberpunk 2077 for me.

I ran into this problem today, the provided link returned a 403 for me.
What I found after searching for hours on the net was a really simple solution.
I downloaded my desired dxvk version, unpacked the tarball into my ~/.local/share/lutris/runtime/dxvk/ folder.
In my case I had to change the foldername from dxvk-1.10.3 to 1.10.3 according to the entry on the runners tab. After restarting Lutris it worked.
I do not know if everone exept me here knows this, I could not find this info in this forum.