Lutris breaks itself by updating

I’ve been using Lutris for a few years and built a PC for my kids with all my favourite games on it so they can play them too. It had all been working great until earlier this year when Lutris started breaking itself if I ever launch it when connected to the internet. I assume it is downloading some kind of update, and subsequently some games don’t run, some run without sound, and some run normally. I’ve tried for days to fix the problem but have always been unable to and end up restoring my hard drive from a backup image.

Here is the issue report generated by lutris:

Please let me know if there is some way to stop Lutris from updating itself, or if the problem can be fixed. After the update or whatever happens games generate various errors about pulseaudio. For example, VVVVVV gives:

ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Protocol error

Braid gives:
ALSA lib conf.c:3523:(snd_config_hooks_call) Cannot open shared library

Some games work normally though, 140 for example.

And I don’t seem to have any sound at all in Retroarch or WINE etc. I’ve tried about a thousand things to resolve the errors themselves, reinstalling PulseAudio etc. and have never been able to resolve this. I’m on Lutris 0.5.4 because I’ve also never managed to upgrade to a newer version without breaking large portions of my game library too.

Is there some way I can stop Lutris from updating itself? Or any other ideas?

1 Like

If you are using any version after 0.5.9-beta1 you can disable self update exporting a system variable: