Back to the main site

Lutris and browser integration


#1

I have both Firefox and Chrome installed. Installed Lutris but I can’t get the browser to recognize the action to launch Lutris when I click on “Install” on any game’s page at lutris.net

As a workaround, I’m adding the game to my library, syncing and then installing from the program. Is there any bit of sourcery I need to add to either Firefox or Chrome in order to open lutris’ links?


How to add a script to Lutris
#2

The browser integration should work. Maybe it’s a problem with the lutris package on your distro? Or running a desktop that isn’t Gnome based?

This file https://github.com/lutris/lutris/blob/master/share/glib-2.0/schemas/apps.lutris.gschema.xml should take care of Lutris links, if properly installed it should work just fine.


#3

Worked here… Ubuntu MATE 16.04, installed via Ubuntu MATE Welcome (PPA).


#4

Hi,

I am using LXDE, and I have the same problem.

Also:
the link: https://github.com/lutris/lutris/blob/master/share/glib-2.0/schemas/apps.lutris.gschema.xml is broken.

Can any one help?


#5

Hi there! I am using manjaro xfce and have the exact same problem. The link is also broken and I cant seem to find a solution! Please help! Thanks!


#6

Running LXDE via Lubuntu, same issue


#7

Is this a regression? Did it used to work?


#8

It is the first time I am installing lutris and it is not working. There’s more when I open the actual lutris app I dont see any of my runners. Here’s a picture:

I click on manage runners and installed a few but I dont even see the firefox and linux runner. in the view tab I have enabled the side panel. Pls help I rly want to start using lutris! Thanks!

EDIT: All of the above I had tested on my laptop which runs manjaro as I have said already. Yesterday I installed Manjaro on some spare space on my HDD on my desktopPC. The isuue is exactly the same so I am wondering maybe lutris is fine and I need to make certain configurations to browser/manjaro/lutris itself to be able to use it?? Idk but I would rly much appreciate any help because league of legends is the only thing that keeps me from deleting my windows partition. Thanks!


#9

Same issue here on KDE NEON


#10

I am also getting this issues.


#11

If you are using firefox, I found a way to fix the issue. I think it’s more firefox’s fault than Lutris’

  1. On firefox, go to about:config. Don’t close the tab just yet
  2. On a new tab, go to lutris’ website > games and open any game page
  3. Switch back to about:config tab and search for network.protocol-handler.expose-all and swtitch it to “False”
  4. tab back to the lutris page and click on the install button, firefox will prompt you if you want to open it with lutris.
  5. Make sure to select the “always use this” option checkbox
  6. tab back to about:config and switch network.protocol-handler.expose-all to true again

#12

wiildrick is correct for firefox
in chromium, installing xdg-open resolves the issue for me


#13

I need to go into firefox debug mode (without addons) to get things to work - it seems that lutris doesn’t play nice with uBlock origin/uMatrix or the other way round. Does anybody know what to whitelist?


#14

thanks , it works for me :smiley:


#15

Had that issue with Firefox on Solus. Thanks for the workaround!


#16

When I click the link where I should choose which application to use, my application list is empty.

Screenshot_20180611_130047

Clicking “Choose…” brings up a file browser.

Is there a way to populate this list, or should I point it to a specific file?

Kubuntu 18.04


#17

I had to run:
sudo update-desktop-database

Or maybe it was without sudo. There is a thread here that might have other solutions: https://github.com/lutris/lutris/issues/608


#18

Thank you @elo

The last comment on that thread had the answer I needed, here it is:

The problem should be reported to Kubuntu, Steam links don't work either. There's something missing in their URL handler implementation.

Currently, the best workaround is go to about:config in Firefox and set

network.protocol-handler.expose-all  to False

then select /usr/bin/xdg-open as the opener for either Lutris or Steam

After selecting /usr/bin/xdg-open, and setting to remember for Lutris links, it works as expected.