Back to the main site

Lutris 0.50 error on Ubuntu 16.04 - Required gtk+ version 3.20


#1

On a Ubuntu 16.04 system, after Lutris was auto-updated to version 0.50 I get the error:

Lib.Error: gtk-builder-error-quark: /usr/share/lutris/ui/runners-dialog.ui:5:1 Required gtk+ version 3.20, current version is 3.18 (7)
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/lutris/gui/lutriswindow.py”, line 601, in on_manage_runners
return RunnersDialog(transient_for=self)
File “/usr/lib/python3/dist-packages/lutris/gui/dialogs/init.py”, line 32, in init
self.builder.add_from_file(ui_filename)

Lutris was installed through the official repository as written on https://lutris.net/downloads/.

Is there an easy way to fix this (other than updating to Ubuntu 18.04)? In the repositoy https://download.opensuse.org/repositories/home:/strycore/xUbuntu_16.04/amd64/ only the newest version 0.50 is available, how can I switch back to the old but working 0.43 release? Is there a backup somewhere?


#3

0.5.0.1 should fix that. Update.


#4

Confirmed, fixed by 0.5.0.1.