Lutris Install Issues - Steam Deck

Hello, so I have had my Steam deck for a little bit now and am attempting to install Lutris with the new flat pack that recently released. I am not new to Linux but also definitely not well versed either.

I was able to install the flatpack fine, and when I launch it, it states that it wants me to install the GL compat extension due to it being missing. Copy the console command it wants me to enter so I can go do that.

From there go to the terminal, plunk it in then get error: No remote refs found similar to ‘flathub’.

I assume I am missing something completely simple, but just cannot seem to figure it out. Any assistance would be greatly appreciated!
all of this just so I can play some diablo lmao

Hi, did you activated the beta stuff?
Check if you performed all the steps here:

Check this tweet also:

Yeah so I followed that, but am still running into the same error. I decided to try and run it as –user flathub-beta and got further. But, it cannot find anything for gnome version 42 under that.

I also did the following after some light googling of
flatpak remote-add --if-not-exists flathub

However, once again same thing on how there are no remote refs found similar to flathub.

I also verified by doing flatpak remote that the name flathub is indeed there for system but not under user. Perhaps I need to remove the user part?

I am basically documenting everything I do so that hopefully if someone else finds this it helps. Removing the –user part of the command did actually allow me to install the correct Gnome .

Alrighty, hit a point of being stuck again. Got all the gnome stuff installed and what not, as well as verified by attempting to install a second time and it skipped. When attempting to run flatpak install --user flathub-beta net.lutris.Lutris//beta I get a new error now being:
error: The application net.lutris.Lutris/x86_64/beta requires the runtime org.gnome.Platform/x86_64/42 which was not found
However, I confirmed earlier that it is indeed installed on the system.


Went back into the discover store and installed lutris again that way and it finally opened! Progress!

1 Like

What a roller coaster, I’m invested now. Let us know if the games work

Yeah at this point I was finally able to get BNet installed and am currently installing Diablo now as I can. I had to use flatseal application on Steam Deck Discover to allow Lutris to actually access the SD card. Will post later once it is finally installed and hopefully works.

1 Like

So eventually it worked, took a lot more tweaking by re-assigning the application in lutris to launch Diablo 3 directly. As well as configuring BNet to close immediately after opening a game or else there would be a weird flicker thing. Thankfully someone made a good controller layout that does work for the game after getting used to it a little bit. Runs at a solid 60fps as well at medium settings until stuff on the screen gets crazy then there are some dips.

1 Like