Low FPS in World of Warcraft Classic with 6800XT

I am experiencing low FPS in WoW Classic with my system (Pop OS, 13600K, 6800 XT). I’m getting about 10-40 fps depending on my in-game graphics settings. Steam games work fine.

WoW was running fine the other day (100+ fps), but then issues cropped up today. I believe that my mesa drivers were just updated to 22.3.5 from 22.2.0 (seemingly from pop repositories).

I have gone through and ensured that the kisa-mesa repository is being given primacy, and that these drivers are installed. However, I’m still having the issue.

Here is an output of “lutris -d” of the game running for a short bit: Ubuntu Pastebin

I have tried runners:
-lutris-7.2-2 (default from the installer)

My system specs are below:

OS: Pop!_OS 22.04 jammy
Arch: x86_64
Kernel: 6.1.11-76060111-generic
Desktop: pop:GNOME
Display Server: x11

Vendor: GenuineIntel
Model: 13th Gen Intel(R) Core™ i5-13600K
Physical cores: 14
Logical cores: 20

RAM: 31.1 GB
Swap: 20.0 GB

Vendor: AMD
OpenGL Renderer: AMD Radeon RX 6800 XT (navi21, LLVM 15.0.7, DRM 3.49, 6.1.11-76060111-generic)
OpenGL Version: 4.6 (Compatibility Profile) Mesa 22.3.5 - kisak-mesa PPA
OpenGL Core: 4.6 (Core Profile) Mesa 22.3.5 - kisak-mesa PPA
OpenGL ES: OpenGL ES 3.2 Mesa 22.3.5 - kisak-mesa PPA
Vulkan: Supported

Any suggestions on how to fix this would be greatly appreciated!

Edit: posted pastebin of lutris -d

Well I found and fixed my issue.

Looking at the lutris -d log, I noticed that both my onboard and my amd gpu were showing up (even though I only use the amd gpu):

INFO 2023-02-22 23:47:35,015 [startup.check_driver:77]:GPU: 1002:73BF 148C:2406 (amdgpu drivers)
INFO 2023-02-22 23:47:35,015 [startup.check_driver:77]:GPU: 8086:A780 1462:7D32 (i915 drivers)

I disabled the onboard gpu in my bios, and it forces Lutris to use the discrete card. Now I’m at 140+ fps.

Not sure if there is a way to force a card through Lutris (instead of the BIOS).

1 Like